summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2023-07-30 20:55:52 +0200
committerToni Uhlig <matzeton@googlemail.com>2023-07-30 20:55:52 +0200
commit2da24be2e8f8ffa60e371557d75183b67fd2ea24 (patch)
treeec436bf94ad75fed1e0779d35a2bd7a64833babd /CMakeLists.txt
parent98c665b409595238d73f550f95c7bf83ec6142da (diff)
Added UI to insert/delete bytes into a packet.
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2df0801..88f7c74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,12 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
+set(CPACK_PACKAGE_CONTACT "toni@impl.cc")
+set(CPACK_DEBIAN_PACKAGE_NAME "pcap-editor")
+set(CPACK_DEBIAN_PACKAGE_SHLIBDEPS ON)
+
include(ExternalProject)
+include(CPack)
find_package(QT NAMES Qt6 REQUIRED COMPONENTS Core Widgets)
find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Core Widgets)
@@ -42,10 +47,15 @@ endif()
set(PROJECT_SOURCES
main.cpp
+
mainwindow.cpp
mainwindow.h
mainwindow.ui
+ bytewindow.cpp
+ bytewindow.h
+ bytewindow.ui
+
pcapplusplus.cpp
pcapplusplus.h