aboutsummaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
Diffstat (limited to 'tools')
-rw-r--r--tools/meson/Makefile4
-rw-r--r--tools/meson/patches/010-wsl2.patch21
2 files changed, 2 insertions, 23 deletions
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index d53ed897a3..f0810ced96 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=meson
-PKG_VERSION:=0.61.5
+PKG_VERSION:=1.1.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=5e9a0d65c1a51936362b9686d1c5e9e184a6fd245d57e7269750ce50c20f5d9a
+PKG_HASH:=d9616c44cd6c53689ff8f05fc6958a693f2e17c3472a8daf83cee55dabff829f
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
PKG_LICENSE:=Apache-2.0
diff --git a/tools/meson/patches/010-wsl2.patch b/tools/meson/patches/010-wsl2.patch
deleted file mode 100644
index 4ab799d699..0000000000
--- a/tools/meson/patches/010-wsl2.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 7d1ef4343ed5b2b7ab51469177a42c32c47f0528 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Tue, 6 Sep 2022 01:36:17 -0700
-Subject: [PATCH] minstall: handle extra error for selinuxenabled
-
-Microsoft's WSL2 uses a Plan 9 filesystem, which returns IOError when file is missing.
----
- mesonbuild/minstall.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/mesonbuild/minstall.py
-+++ b/mesonbuild/minstall.py
-@@ -229,7 +229,7 @@ def restore_selinux_contexts() -> None:
- '''
- try:
- subprocess.check_call(['selinuxenabled'])
-- except (FileNotFoundError, NotADirectoryError, PermissionError, subprocess.CalledProcessError):
-+ except (FileNotFoundError, NotADirectoryError, OSError, PermissionError, subprocess.CalledProcessError):
- # If we don't have selinux or selinuxenabled returned 1, failure
- # is ignored quietly.
- return