aboutsummaryrefslogtreecommitdiff
path: root/tools/mold
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mold')
-rw-r--r--tools/mold/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/mold/Makefile b/tools/mold/Makefile
new file mode 100644
index 0000000000..e8fcecbfed
--- /dev/null
+++ b/tools/mold/Makefile
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mold
+PKG_VERSION:=1.11.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL_FILE:=v$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/rui314/mold/archive/refs/tags
+PKG_HASH:=99318eced81b09a77e4c657011076cc8ec3d4b6867bd324b8677974545bc4d6f
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_HOST_OPTIONS += \
+ -DMOLD_LTO=ON \
+ -DMOLD_MOSTLY_STATIC=ON \
+ -DMOLD_USE_SYSTEM_MIMALLOC=OFF \
+ -DMOLD_USE_SYSTEM_TBB=OFF
+
+$(eval $(call HostBuild))