aboutsummaryrefslogtreecommitdiff
path: root/target/linux/starfive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/starfive/Makefile')
-rw-r--r--target/linux/starfive/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/starfive/Makefile b/target/linux/starfive/Makefile
new file mode 100644
index 0000000000..f71f57e7f7
--- /dev/null
+++ b/target/linux/starfive/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2024 Toco Technologies <info@toco.ae>
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=riscv64
+BOARD:=starfive
+BOARDNAME:=StarFive JH71x0 (7100/7110)
+FEATURES:=ext4
+KERNELNAME:=Image dtbs
+
+KERNEL_PATCHVER:=6.1
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for the StarFive JH71x0-based boards
+endef
+
+$(eval $(call BuildTarget))