aboutsummaryrefslogtreecommitdiff
path: root/package/utils
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils')
4 files changed, 31 insertions, 49 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 90724eb3f6..2ab72a2d2c 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
-PKG_VERSION:=2.39
-PKG_RELEASE:=2
+PKG_VERSION:=2.39.2
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.39
-PKG_HASH:=32b30a336cda903182ed61feb3e9b908b762a5e66fe14e43efb88d37162075cb
+PKG_HASH:=87abdfaa8e490f8be6dde976f7c80b9b5ff9f301e1b67e3899e1f05a59a1531f
PKG_CPE_ID:=cpe:/a:kernel:util-linux
PKG_LICENSE:=GPL-2.0-only
diff --git a/package/utils/util-linux/patches/0001-test_enosys-add-support-for-mips.patch b/package/utils/util-linux/patches/0001-test_enosys-add-support-for-mips.patch
deleted file mode 100644
index f8c8f851ec..0000000000
--- a/package/utils/util-linux/patches/0001-test_enosys-add-support-for-mips.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 2558932c65524d953e4c86d7fda2282a582aa5ec Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
-Date: Wed, 17 May 2023 16:50:47 +0200
-Subject: [PATCH] test_enosys: add support for mips, powerpc and arc
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
----
- tests/helpers/test_enosys.c | 14 ++
- 1 file changed, 2 insertions(+)
-
---- a/tests/helpers/test_enosys.c
-+++ b/tests/helpers/test_enosys.c
-@@ -53,6 +53,20 @@
- # else
- # define SECCOMP_ARCH_NATIVE AUDIT_ARCH_PPC64LE
- # endif
-+#elif __powerpc__
-+# define SECCOMP_ARCH_NATIVE AUDIT_ARCH_PPC
-+#elif __mips__
-+# if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
-+# define SECCOMP_ARCH_NATIVE AUDIT_ARCH_MIPS
-+# else
-+# define SECCOMP_ARCH_NATIVE AUDIT_ARCH_MIPSEL
-+# endif
-+#elif __arc__
-+# if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
-+# define SECCOMP_ARCH_NATIVE AUDIT_ARCH_ARCV2BE
-+# else
-+# define SECCOMP_ARCH_NATIVE AUDIT_ARCH_ARCV2
-+# endif
- #else
- # error Unknown target architecture
- #endif
diff --git a/package/utils/util-linux/patches/001-meson-properly-handle-gettext-non-existence.patch b/package/utils/util-linux/patches/001-meson-properly-handle-gettext-non-existence.patch
new file mode 100644
index 0000000000..f3d49d8d2d
--- /dev/null
+++ b/package/utils/util-linux/patches/001-meson-properly-handle-gettext-non-existence.patch
@@ -0,0 +1,28 @@
+From b8bed37a1493b913bf5bda938487ae0c06c11ce7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
+Date: Sat, 5 Aug 2023 08:57:28 +0200
+Subject: [PATCH] meson: properly handle gettext non-existence
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Commit e91a49c9747f ("meson: don't build po if no gettext")
+tried to add the possibility to build util-linux without gettext.
+
+Unfortunately by default the call to find_program() would abort the
+build if the program is not found.
+Avoid aborting the build.
+
+Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
+---
+ po/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/po/meson.build
++++ b/po/meson.build
+@@ -1,4 +1,4 @@
+-if not find_program('gettext').found()
++if not find_program('gettext', required : false).found()
+ subdir_done()
+ endif
+
diff --git a/package/utils/util-linux/patches/200-meson-no-po.patch b/package/utils/util-linux/patches/200-meson-no-po.patch
deleted file mode 100644
index 4d94f6b89a..0000000000
--- a/package/utils/util-linux/patches/200-meson-no-po.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -874,7 +874,6 @@ subdir('disk-utils')
- subdir('misc-utils')
- subdir('text-utils')
- subdir('term-utils')
--subdir('po')
-
- includes = [dir_include,
- dir_libblkid,