aboutsummaryrefslogtreecommitdiff
path: root/package/kernel/leds-gca230718/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/leds-gca230718/Makefile')
-rw-r--r--package/kernel/leds-gca230718/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/kernel/leds-gca230718/Makefile b/package/kernel/leds-gca230718/Makefile
new file mode 100644
index 0000000000..a1ae3bc319
--- /dev/null
+++ b/package/kernel/leds-gca230718/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2008-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=leds-gca230718
+PKG_RELEASE:=1
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/leds-gca230718
+ SUBMENU:=LED modules
+ TITLE:=GCA230718 LED support (e.g. for D-Link M30)
+ FILES:= \
+ $(PKG_BUILD_DIR)/leds-gca230718.ko
+ AUTOLOAD:=$(call AutoProbe,leds-gca230718,1)
+ DEPENDS:=@TARGET_mediatek_filogic
+endef
+
+define KernelPackage/leds-gca230718/description
+ GCA230718 LED support (e.g. for D-Link M30) using I2C.
+endef
+
+define Build/Compile
+ $(KERNEL_MAKE) M="$(PKG_BUILD_DIR)" modules
+endef
+
+$(eval $(call KernelPackage,leds-gca230718))