aboutsummaryrefslogtreecommitdiff
path: root/include/meson.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/meson.mk')
-rw-r--r--include/meson.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/meson.mk b/include/meson.mk
index 74c9d3dd7f..65716746fe 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -98,6 +98,7 @@ endef
define Host/Configure/Meson
$(call Meson/CreateNativeFile,$(HOST_BUILD_DIR)/openwrt-native.txt)
$(call Meson, \
+ setup \
--native-file $(HOST_BUILD_DIR)/openwrt-native.txt \
$(MESON_HOST_ARGS) \
$(MESON_HOST_BUILD_DIR) \
@@ -121,6 +122,7 @@ define Build/Configure/Meson
$(call Meson/CreateNativeFile,$(PKG_BUILD_DIR)/openwrt-native.txt)
$(call Meson/CreateCrossFile,$(PKG_BUILD_DIR)/openwrt-cross.txt)
$(call Meson, \
+ setup \
--buildtype plain \
--native-file $(PKG_BUILD_DIR)/openwrt-native.txt \
--cross-file $(PKG_BUILD_DIR)/openwrt-cross.txt \