aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--include/meson.mk1
-rw-r--r--tools/meson/Makefile1
-rw-r--r--tools/meson/files/openwrt-cross.txt.in2
3 files changed, 4 insertions, 0 deletions
diff --git a/include/meson.mk b/include/meson.mk
index 7d67dcf298..74c9d3dd7f 100644
--- a/include/meson.mk
+++ b/include/meson.mk
@@ -78,6 +78,7 @@ define Meson/CreateCrossFile
$(STAGING_DIR_HOST)/bin/sed \
-e "s|@CC@|$(foreach BIN,$(TARGET_CC),'$(BIN)',)|" \
-e "s|@CXX@|$(foreach BIN,$(TARGET_CXX),'$(BIN)',)|" \
+ -e "s|@LD@|$(foreach FLAG,$(TARGET_LINKER),'$(FLAG)',)|" \
-e "s|@AR@|$(TARGET_AR)|" \
-e "s|@STRIP@|$(TARGET_CROSS)strip|" \
-e "s|@NM@|$(TARGET_NM)|" \
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index b115e0802b..f957bfb49f 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -2,6 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=meson
PKG_VERSION:=1.1.1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
diff --git a/tools/meson/files/openwrt-cross.txt.in b/tools/meson/files/openwrt-cross.txt.in
index ec4b027f1b..ba11915069 100644
--- a/tools/meson/files/openwrt-cross.txt.in
+++ b/tools/meson/files/openwrt-cross.txt.in
@@ -1,6 +1,8 @@
[binaries]
c = [@CC@]
+c_ld = [@LD@]
cpp = [@CXX@]
+cpp_ld = [@LD@]
ar = '@AR@'
strip = '@STRIP@'
nm = '@NM@'