aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tools/coreutils/Makefile14
-rw-r--r--tools/coreutils/patches/000-bootstrap.patch2
-rw-r--r--tools/coreutils/patches/001-bootstrap-sync.patch73
3 files changed, 6 insertions, 83 deletions
diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index 184281f0be..f55fdcc1b2 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=coreutils
PKG_CPE_ID:=cpe:/a:gnu:coreutils
-PKG_VERSION:=9.4
+PKG_VERSION:=9.5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/coreutils
-PKG_HASH:=5f600d9093973b0afe25393d9bc18c44f2232657f4ca0d95ea31c702eb66b739
+PKG_HASH:=767ae6a22950ec42f3ba5f7c1de79dd27800ee8e9b8642da5dedb5974a1741e5
HOST_BUILD_PARALLEL := 1
@@ -23,13 +23,9 @@ include $(INCLUDE_DIR)/host-build.mk
export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
HOST_GNULIB_SKIP := \
- lib/math.in.h \
- lib/stdlib.in.h \
- lib/string.in.h \
- lib/uchar.in.h \
- lib/unistd.in.h \
- lib/wchar.in.h \
- lib/wctype.in.h
+ lib/nstrftime.c \
+ lib/fprintftime.c \
+ lib/locale.in.h
HOST_CONFIGURE_ARGS += \
--disable-year2038 \
diff --git a/tools/coreutils/patches/000-bootstrap.patch b/tools/coreutils/patches/000-bootstrap.patch
index 3faaa946f1..68db19084f 100644
--- a/tools/coreutils/patches/000-bootstrap.patch
+++ b/tools/coreutils/patches/000-bootstrap.patch
@@ -34,7 +34,7 @@
if [ ! "$inst_ver" ]; then
warn_ "Error: '$app' not found"
ret=1
-@@ -1155,7 +1155,7 @@ autogen()
+@@ -1157,7 +1157,7 @@ autogen()
# two just-pre-run programs.
# Import from gettext.
diff --git a/tools/coreutils/patches/001-bootstrap-sync.patch b/tools/coreutils/patches/001-bootstrap-sync.patch
deleted file mode 100644
index 1b9687733f..0000000000
--- a/tools/coreutils/patches/001-bootstrap-sync.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From 9becda5d9371c16a6e5e2815c8a28158696e4a23 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?P=C3=A1draig=20Brady?= <P@draigBrady.com>
-Date: Sun, 10 Dec 2023 19:04:59 +0000
-Subject: build: update gnulib submodule to latest
-
-* bootstrap: Copy from latest Gnulib,
-to fix --bootstrap-sync with other options.
----
- bootstrap | 16 ++++++++++------
- 1 file changed, 10 insertions(+), 6 deletions(-)
-
-(limited to 'bootstrap')
-
---- a/bootstrap
-+++ b/bootstrap
-@@ -3,7 +3,7 @@
-
- # Bootstrap this package from checked-out sources.
-
--scriptversion=2023-07-01.18; # UTC
-+scriptversion=2023-12-10.18; # UTC
-
- # Copyright (C) 2003-2023 Free Software Foundation, Inc.
- #
-@@ -37,7 +37,7 @@ medir=`dirname "$me"`
-
- # A library of shell functions for autopull.sh, autogen.sh, and bootstrap.
-
--scriptlibversion=2023-07-01.17; # UTC
-+scriptlibversion=2023-12-10.18; # UTC
-
- # Copyright (C) 2003-2023 Free Software Foundation, Inc.
- #
-@@ -659,7 +659,9 @@ Optional environment variables:
- Use this if you already have gnulib sources
- and history on your machine, and do not want
- to waste your bandwidth downloading them again.
-- GNULIB_URL Cloneable URL of the gnulib repository.
-+ GNULIB_URL URL of the gnulib repository. The default is
-+ $default_gnulib_url,
-+ which is Gnulib's upstream repository.
-
- Options:
- --bootstrap-sync if this bootstrap script is not identical to
-@@ -775,7 +777,7 @@ autopull()
- if $use_gnulib || $bootstrap_sync; then
- prepare_GNULIB_SRCDIR
- if $bootstrap_sync; then
-- upgrade_bootstrap
-+ upgrade_bootstrap "$@"
- fi
- fi
-
-@@ -1347,7 +1349,9 @@ Optional environment variables:
- have gnulib sources on your machine, and
- do not want to waste your bandwidth downloading
- them again.
-- GNULIB_URL Cloneable URL of the gnulib repository.
-+ GNULIB_URL URL of the gnulib repository. The default is
-+ $default_gnulib_url,
-+ which is Gnulib's upstream repository.
-
- Options:
-
-@@ -1492,7 +1496,7 @@ check_build_prerequisites $use_git
-
- if $bootstrap_sync; then
- prepare_GNULIB_SRCDIR
-- upgrade_bootstrap
-+ upgrade_bootstrap "$@"
- # Since we have now upgraded if needed, no need to try it a second time below.
- bootstrap_sync=false
- fi