aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tools/cmake/patches/160-disable_xcode_generator.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/cmake/patches/160-disable_xcode_generator.patch b/tools/cmake/patches/160-disable_xcode_generator.patch
new file mode 100644
index 0000000000..20d1086bd4
--- /dev/null
+++ b/tools/cmake/patches/160-disable_xcode_generator.patch
@@ -0,0 +1,22 @@
+--- a/Source/CMakeLists.txt
++++ b/Source/CMakeLists.txt
+@@ -846,7 +846,7 @@ if(CMake_USE_XCOFF_PARSER)
+ endif()
+
+ # Xcode only works on Apple
+-if(APPLE)
++if(APPLE_DISABLED)
+ target_sources(
+ CMakeLib
+ PRIVATE
+--- a/Source/cmake.cxx
++++ b/Source/cmake.cxx
+@@ -132,7 +132,7 @@
+ # include "cmGlobalGhsMultiGenerator.h"
+ #endif
+
+-#if defined(__APPLE__)
++#if defined(__APPLE_DISABLED__)
+ # if !defined(CMAKE_BOOTSTRAP)
+ # include "cmGlobalXCodeGenerator.h"
+