aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/usb.mk11
-rw-r--r--target/linux/gemini/modules.mk14
2 files changed, 14 insertions, 11 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 721e17f970..644365ed19 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -331,17 +331,6 @@ define KernelPackage/usb-bcma
endef
$(eval $(call KernelPackage,usb-bcma))
-define KernelPackage/usb-fotg210
- TITLE:=Support for FOTG210 USB host controllers
- DEPENDS:=@USB_SUPPORT @TARGET_gemini
- KCONFIG:=CONFIG_USB_FOTG210_HCD
- FILES:= \
- $(if $(CONFIG_USB_FOTG210_HCD),$(LINUX_DIR)/drivers/usb/host/fotg210-hcd.ko)
- AUTOLOAD:=$(call AutoLoad,50,fotg210-hcd,1)
- $(call AddDepends/usb)
-endef
-$(eval $(call KernelPackage,usb-fotg210))
-
define KernelPackage/usb-ssb
TITLE:=Support for SSB USB controllers
DEPENDS:=@USB_SUPPORT @TARGET_bcm47xx
diff --git a/target/linux/gemini/modules.mk b/target/linux/gemini/modules.mk
new file mode 100644
index 0000000000..104ad90279
--- /dev/null
+++ b/target/linux/gemini/modules.mk
@@ -0,0 +1,14 @@
+define KernelPackage/usb-fotg210
+ TITLE:=Support for FOTG210 USB host and device controllers
+ DEPENDS:=@USB_SUPPORT @TARGET_gemini
+ KCONFIG:=CONFIG_USB_FOTG210 \
+ CONFIG_USB_FOTG210_HCD
+ FILES:=$(if $(CONFIG_USB_FOTG210_HCD),$(LINUX_DIR)/drivers/usb/host/fotg210-hcd.ko@lt6.1) \
+ $(if $(CONFIG_USB_FOTG210),$(LINUX_DIR)/drivers/usb/fotg210/fotg210.ko@ge6.1)
+ AUTOLOAD:=$(call AutoLoad,50, \
+ $(if $(CONFIG_USB_FOTG210_HCD),fotg210-hcd@lt6.1) \
+ $(if $(CONFIG_USB_FOTG210),fotg210@ge6.1),1)
+ $(call AddDepends/usb)
+endef
+
+$(eval $(call KernelPackage,usb-fotg210))