aboutsummaryrefslogtreecommitdiff
path: root/tools/zstd/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-04-06 14:58:48 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-04-06 14:58:48 +0200
commitf2fabf7aaaacec6fdc50226f57f4be2c19d8cace (patch)
treebbfb0c4ebe91c1dc846935b40060a7a08a1d34d6 /tools/zstd/Makefile
parent0a0d89265ee474d0784f675d65685ed011cc30b3 (diff)
tools: zstd: add patch fixing wrong generated .pc with lib-mt
The current .pc generated by make build system for zstd is wrong and always assume a single-threaded library is used. This wasn't the case for the meson build system that used his own logic to generate the pkg-config file. Add a patch to fix this by introducing install-mt-pc make target to generate the correct pkg-config gile. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools/zstd/Makefile')
-rw-r--r--tools/zstd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
index 2bb055c93d..728cef26b8 100644
--- a/tools/zstd/Makefile
+++ b/tools/zstd/Makefile
@@ -34,7 +34,7 @@ define Host/Compile
endef
define Host/Install
- +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/lib install-pc install-static install-includes PREFIX=$(HOST_BUILD_PREFIX)
+ +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/lib install-mt-pc install-static install-includes PREFIX=$(HOST_BUILD_PREFIX)
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/programs install PREFIX=$(HOST_BUILD_PREFIX)
endef