aboutsummaryrefslogtreecommitdiff
path: root/tools/zstd/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-04-17 11:28:58 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-04-17 11:29:14 +0200
commit2b6923bc7601c732a62d0e169c69106638af0a84 (patch)
treeda4217bbfa7d44b5ae148e4fac47713b6cd473f6 /tools/zstd/Makefile
parent44a3c18a31a2a40cd502261016dc60433006cae8 (diff)
tools: zstd: update patch with upstream version
Proposed fixup has been replaced and merged with an advanced version. install-pc-mt has been dropped and replaced for intall-pc MT=1 to generate a .pc file with multithread libs. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools/zstd/Makefile')
-rw-r--r--tools/zstd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
index 0264ac2422..f962809f82 100644
--- a/tools/zstd/Makefile
+++ b/tools/zstd/Makefile
@@ -31,7 +31,8 @@ define Host/Compile
endef
define Host/Install
- +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/lib install-mt-pc install-static install-includes PREFIX=$(HOST_BUILD_PREFIX)
+ +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/lib install-static install-includes PREFIX=$(HOST_BUILD_PREFIX)
+ +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/lib install-pc MT=1 PREFIX=$(HOST_BUILD_PREFIX)
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/programs install PREFIX=$(HOST_BUILD_PREFIX)
endef