aboutsummaryrefslogtreecommitdiff
path: root/tools/cmake/patches
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-12-11 16:18:58 +0100
committerNick Hainke <vincent@systemli.org>2023-12-12 00:44:31 +0100
commit0827fb8cc3ab1e6ed0bfcdefdc27425de863ed91 (patch)
treec249712249b94945d9c30e1837125ec4f54d33aa /tools/cmake/patches
parent957a0921e20257bd94b7f5ace6e07a68e8388499 (diff)
tools/cmake: update to 3.28.0
Release Notes: - https://www.kitware.com/cmake-3-28-0-available-for-download/ Refresh patches: - 120-curl-fix-libressl-linking.patch - 130-bootstrap_parallel_make_flag.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools/cmake/patches')
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index b899d1d7ef..9d1d86c325 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -590,6 +590,14 @@ if(CURL_USE_OPENSSL)
+@@ -650,6 +650,14 @@ if(CURL_USE_OPENSSL)
endif()
set(SSL_ENABLED ON)
set(USE_OPENSSL ON)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 983f376254..557e27a612 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1486,7 +1486,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1491,7 +1491,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if test "x${cmake_parallel_make}" != "x"; then