aboutsummaryrefslogtreecommitdiff
path: root/tools/Makefile
diff options
context:
space:
mode:
authorWeijie Gao <hackpascal@gmail.com>2024-01-09 23:20:18 +0800
committerRobert Marko <robimarko@gmail.com>2024-03-11 20:17:25 +0100
commit53e3851646f872a08010709c6503d4bc838b5a0b (patch)
treebbaa451b39c3865b0bad4386b955a9f3284b144c /tools/Makefile
parentecc9d0195b2411bd38c5deae38f255026c20c970 (diff)
tools: add util-linux
since kernel 6.4, commit bca2f3a9406b ("efi/zboot: Add BSS padding before compression") introduces the use of hexdump to padding the EFI kernel binary before compression. util-linux which containing hexdump should then be compiled as a host tool to guarantee not breaking the kernel build process. Signed-off-by: Weijie Gao <hackpascal@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index bc169d7a95..7607e84481 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -66,6 +66,7 @@ tools-y += pkgconf
tools-y += quilt
tools-y += squashfs4
tools-y += sstrip
+tools-y += util-linux
tools-y += zip
tools-y += zlib
tools-y += zstd
@@ -128,6 +129,7 @@ $(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compil
$(curdir)/sdcc/compile := $(curdir)/bison/compile
$(curdir)/squashfs3-lzma/compile := $(curdir)/lzma-old/compile
$(curdir)/squashfs4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
+$(curdir)/util-linux/compile := $(curdir)/bison/compile
$(curdir)/zstd/compile := $(curdir)/meson/compile
ifneq ($(HOST_OS),Linux)