aboutsummaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-05-30 16:36:05 +0200
committerPetr Štetiar <ynezz@true.cz>2023-06-05 08:31:40 +0200
commita9be186466fdb4987c158916781d99329d1c3712 (patch)
treece028919696471c5741fc4fff6d08295da2aa817 /target
parentfdea7cb61776192ddb808a639af0a585d5b01b5b (diff)
ipq807x: image: factor out common eMMC bits
For better maintainability and reusability. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq807x/image/generic.mk21
1 files changed, 12 insertions, 9 deletions
diff --git a/target/linux/ipq807x/image/generic.mk b/target/linux/ipq807x/image/generic.mk
index 7a216b810c..1ea42845f0 100644
--- a/target/linux/ipq807x/image/generic.mk
+++ b/target/linux/ipq807x/image/generic.mk
@@ -10,6 +10,13 @@ define Device/FitImageLzma
KERNEL_NAME := Image
endef
+define Device/EmmcImage
+ IMAGES += factory.bin sysupgrade.bin
+ IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
+ DEVICE_PACKAGES := e2fsprogs kmod-fs-ext4 losetup
+endef
+
define Device/UbiFit
KERNEL_IN_UBI := 1
IMAGES := factory.ubi sysupgrade.bin
@@ -103,15 +110,13 @@ TARGET_DEVICES += netgear_wax218
define Device/qnap_301w
$(call Device/FitImage)
+ $(call Device/EmmcImage)
DEVICE_VENDOR := QNAP
DEVICE_MODEL := 301w
DEVICE_DTS_CONFIG := config@hk01
KERNEL_SIZE := 16384k
SOC := ipq8072
- IMAGES += factory.bin sysupgrade.bin
- IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
- IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ipq-wifi-qnap_301w e2fsprogs kmod-fs-ext4 losetup
+ DEVICE_PACKAGES += ipq-wifi-qnap_301w
endef
TARGET_DEVICES += qnap_301w
@@ -162,14 +167,12 @@ TARGET_DEVICES += xiaomi_ax9000
define Device/zyxel_nbg7815
$(call Device/FitImage)
+ $(call Device/EmmcImage)
DEVICE_VENDOR := ZYXEL
DEVICE_MODEL := NBG7815
DEVICE_DTS_CONFIG := config@nbg7815
SOC := ipq8074
- IMAGES += factory.bin sysupgrade.bin
- IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
- IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci e2fsprogs kmod-fs-ext4 losetup \
- kmod-hwmon-tmp103 kmod-bluetooth
+ DEVICE_PACKAGES += ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci kmod-hwmon-tmp103 \
+ kmod-bluetooth
endef
TARGET_DEVICES += zyxel_nbg7815