aboutsummaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-02-16 05:18:47 +0000
committerDaniel Golle <daniel@makrotopia.org>2024-02-16 05:18:47 +0000
commitdc0cf0fc509d7d2ae1250144d4615275094b943e (patch)
tree53172bd4392d5609d0811bd085c310fae613d4f1 /target/linux
parent4d3f6e1b43ccde413322a7b6ac0c6f21456ac187 (diff)
ramips: mt76x8: fix build due to renamed U-Boot binary
The U-Boot binary for the RAVPower RP-WD009 has been renamed. In order to be uniform with all other U-Boot binaries generated the SoC type has been prepended. Set that new name also in the image build recipe for that device in order to fix build. Fixes: 927334a8f7 ("uboot-mediatek: add basic build for ZBT-WG3526 (MT7621, 16M SPI-NOR)") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 9a458d38f3..656820be14 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -493,7 +493,7 @@ define Device/ravpower_rp-wd009
IMAGE_SIZE := 14272k
DEVICE_VENDOR := RAVPower
DEVICE_MODEL := RP-WD009
- UBOOT_PATH := $(STAGING_DIR_IMAGE)/ravpower_rp-wd009-u-boot.bin
+ UBOOT_PATH := $(STAGING_DIR_IMAGE)/mt7628_ravpower_rp-wd009-u-boot.bin
DEVICE_PACKAGES := kmod-mt76x0e kmod-usb2 kmod-usb-ohci \
kmod-sdhci-mt7620 kmod-i2c-mt7628 ravpower-mcu
IMAGES += factory.bin