aboutsummaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-04-18 03:34:23 +0000
committerPetr Štetiar <ynezz@true.cz>2023-06-02 11:36:33 +0200
commitabbffe55ddded36d2a4d0eee6e96c742eaffbbd2 (patch)
treecc8b98e4f6164af666e0e7319014dda1690cc3bb /target/linux
parent847467a5729995a98aa34329f6fa0ed4cb79d210 (diff)
armvirt: package and select Rockchip DWMAC Ethernet driver
For devices that implement the "rockchip,*-gmac" compatible controller, including: - RK3328 - RK3399 - RK3568 - RK3588 - PX30 Signed-off-by: Mathew McBride <matt@traverse.com.au>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/armvirt/image/Makefile4
-rw-r--r--target/linux/armvirt/modules.mk11
2 files changed, 13 insertions, 2 deletions
diff --git a/target/linux/armvirt/image/Makefile b/target/linux/armvirt/image/Makefile
index 533a17b522..8642c88a49 100644
--- a/target/linux/armvirt/image/Makefile
+++ b/target/linux/armvirt/image/Makefile
@@ -109,8 +109,8 @@ define Device/generic
kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
- kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
- kmod-sfp kmod-phy-marvell-10g kmod-atlantic
+ kmod-dwmac-rockchip kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom \
+ kmod-phy-marvell kmod-phy-marvell-10g kmod-sfp kmod-atlantic
endef
TARGET_DEVICES += generic
diff --git a/target/linux/armvirt/modules.mk b/target/linux/armvirt/modules.mk
index 5c863824d3..c59301aae7 100644
--- a/target/linux/armvirt/modules.mk
+++ b/target/linux/armvirt/modules.mk
@@ -245,6 +245,17 @@ endef
$(eval $(call KernelPackage,dwmac-sun8i))
+define KernelPackage/dwmac-rockchip
+ SUBMENU=$(NETWORK_DEVICES_MENU)
+ TITLE:=Rockchip RK3328/RK3399/RK3568 Ethernet
+ DEPENDS:=+kmod-stmmac-core +kmod-mdio-bus-mux
+ KCONFIG:=CONFIG_DWMAC_ROCKCHIP
+ FILES=$(LINUX_DIR)/drivers/net/ethernet/stmicro/stmmac/dwmac-rk.ko
+ AUTOLOAD=$(call AutoLoad,45,dwmac-rk)
+endef
+
+$(eval $(call KernelPackage,dwmac-rockchip))
+
define KernelPackage/thunderx-net
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Marvell (Cavium) ThunderX/2 network drivers