aboutsummaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-08-14 13:47:49 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-08-14 19:28:56 +0200
commit9e9dc1890c6f58d858208136ecfa435445dfca09 (patch)
tree28d73b4bd3dcee1f361d0de5f8b5ecd7d090acfb /target/linux
parent00ce1c05877ac38f5ff00c1c2ce3468d5168f76c (diff)
ipq40xx: commonize Meraki recipe
MR33 and MR74 share pretty much everything in the image recipe, so lets extract a common recipe to avoid duplication. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ipq40xx/image/generic.mk15
1 files changed, 7 insertions, 8 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index a9dd2aa091..55e143e0dd 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -756,26 +756,25 @@ define Device/luma_wrtq-329acn
endef
TARGET_DEVICES += luma_wrtq-329acn
-define Device/meraki_mr33
+define Device/meraki_common
$(call Device/FitImage)
DEVICE_VENDOR := Cisco Meraki
- DEVICE_MODEL := MR33
SOC := qcom-ipq4029
BLOCKSIZE := 128k
PAGESIZE := 2048
DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
+endef
+
+define Device/meraki_mr33
+ $(call Device/meraki_common)
+ DEVICE_MODEL := MR33
DEFAULT := n
endef
TARGET_DEVICES += meraki_mr33
define Device/meraki_mr74
- $(call Device/FitImage)
- DEVICE_VENDOR := Cisco Meraki
+ $(call Device/meraki_common)
DEVICE_MODEL := MR74
- SOC := qcom-ipq4029
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
DEVICE_DTS_CONFIG := config@3
DEFAULT := n
endef