aboutsummaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorMarcin Gajda <mgajda@o2.pl>2024-02-24 17:49:49 +0100
committerRobert Marko <robimarko@gmail.com>2024-02-24 19:49:39 +0100
commit6d8b36bfd821aecc32a4357062ae83a6b3bcd2a9 (patch)
treec50969d651a414292305d2dadc39e854f058f1b3 /target/linux
parent33e72e0b3d3ba90b2eeeab1c61ff8597693c000d (diff)
ipq40xx: Netgear LBR20 fix for proper img builds
Without UBINIZE_OPTS it is possile to have error: "ubi0 error: ubi_attach_mtd_dev: failed to atach mtd23, error -22" This solve this problem. Signed-off-by: Marcin Gajda <mgajda@o2.pl>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ipq40xx/image/generic.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 61bc0ad619..8a83e27f54 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -849,6 +849,7 @@ define Device/netgear_lbr20
KERNEL_SIZE := 7340032
BLOCKSIZE := 128k
PAGESIZE := 2048
+ UBINIZE_OPTS := -E 5
IMAGE/factory.img := append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | \
append-ubi | netgear-dni