aboutsummaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-11-09 15:29:39 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-10 12:30:34 +0100
commit4fdd5530a7ffba356ea9768769ed1713beb7445a (patch)
treede9feb42205e378276f22cea232171a17a1f7645 /target/linux
parent01d675687ca34aa1eb5b05ad8268a130dc2e2b5a (diff)
ipq806x: setup DSA port conduit in board.d
Now that netifd and uci-defaults.sh supports a way to setup DSA port conduit without using iproute2 tool, set DSA port conduit directly in board.d, that will fill board.d and will instruct netifd to setup the port. Drop special init.d qca8k_set_port script and ip-tiny from target dep as they are not required anymore. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ipq806x/Makefile2
-rw-r--r--target/linux/ipq806x/base-files/etc/board.d/02_network7
-rwxr-xr-xtarget/linux/ipq806x/base-files/etc/init.d/qca8k_set_port45
3 files changed, 8 insertions, 46 deletions
diff --git a/target/linux/ipq806x/Makefile b/target/linux/ipq806x/Makefile
index 1bcea1fa80..74a0007a4e 100644
--- a/target/linux/ipq806x/Makefile
+++ b/target/linux/ipq806x/Makefile
@@ -21,6 +21,6 @@ DEFAULT_PACKAGES += \
kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-phy-qcom-ipq806x-usb kmod-usb3 kmod-usb-dwc3-qcom \
kmod-ath10k-ct wpad-basic-mbedtls \
- uboot-envtools ip-tiny
+ uboot-envtools
$(eval $(call BuildTarget))
diff --git a/target/linux/ipq806x/base-files/etc/board.d/02_network b/target/linux/ipq806x/base-files/etc/board.d/02_network
index a4316272e9..7fdda7cfec 100644
--- a/target/linux/ipq806x/base-files/etc/board.d/02_network
+++ b/target/linux/ipq806x/base-files/etc/board.d/02_network
@@ -34,10 +34,17 @@ ipq806x_setup_interfaces()
tplink,ad7200 |\
zyxel,nbg6817)
ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
+ ucidef_set_network_device_conduit "lan1" "eth1"
+ ucidef_set_network_device_conduit "lan2" "eth1"
+ ucidef_set_network_device_conduit "lan3" "eth1"
+ ucidef_set_network_device_conduit "lan4" "eth1"
+ ucidef_set_network_device_conduit "wan" "eth0"
;;
asus,onhub |\
tplink,onhub)
ucidef_set_interfaces_lan_wan "lan1" "wan"
+ ucidef_set_network_device_conduit "lan1" "eth1"
+ ucidef_set_network_device_conduit "wan" "eth0"
;;
edgecore,ecw5410 |\
extreme,ap3935)
diff --git a/target/linux/ipq806x/base-files/etc/init.d/qca8k_set_port b/target/linux/ipq806x/base-files/etc/init.d/qca8k_set_port
deleted file mode 100755
index bf14907b8f..0000000000
--- a/target/linux/ipq806x/base-files/etc/init.d/qca8k_set_port
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=15
-
-set_qca8k_port() {
- local port=$1
- local master=$2
-
- ip link set $port type dsa conduit $master
-}
-
-boot() {
- # Restore original implementation where the eth1 (port 6) was used
- # for the lan port and the eth0 (port 0) was used for the wan port
- case $(board_name) in
- askey,rt4230w-rev6 |\
- asrock,g10 |\
- buffalo,wxr-2533dhp |\
- compex,wpq864 |\
- nec,wg2600hp |\
- nec,wg2600hp3 |\
- netgear,d7800 |\
- netgear,r7500 |\
- netgear,r7500v2 |\
- netgear,r7800 |\
- netgear,xr450 |\
- netgear,xr500 |\
- nokia,ac400i |\
- tplink,ad7200 |\
- tplink,c2600 |\
- tplink,vr2600v |\
- zyxel,nbg6817)
- set_qca8k_port lan1 eth1
- set_qca8k_port lan2 eth1
- set_qca8k_port lan3 eth1
- set_qca8k_port lan4 eth1
- set_qca8k_port wan eth0
- ;;
- asus,onhub |\
- tplink,onhub)
- set_qca8k_port lan1 eth1
- set_qca8k_port wan eth0
- ;;
- esac
-}