aboutsummaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2024-03-19 21:25:52 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2024-03-30 01:04:17 +0100
commit085feb60adf621d6cae8fd6cc7d6a2d84eb3314a (patch)
treedde8c29d96b61935e1c82b86706c315b4043527e /target/linux
parent8201e402c5485817eaf8838347b35e48f7086739 (diff)
ath79: move D-Link DAP-1720 A1 to tiny sub-target
This device only has 64 MiB RAM and ath10k wireless driver will consume a lot of memory. Let's move it to the tiny sub-target to get extra 7 MiB of free space. In this way, we can extend their lifetime to receive support for the next OpenWrt LTS version. This patch also trims the duplicate "recovery.bin" image as it's the same as the "factory.bin". Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds7
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/etc/uci-defaults/09_fix-checksum1
-rw-r--r--target/linux/ath79/image/generic.mk16
-rw-r--r--target/linux/ath79/image/tiny.mk13
-rw-r--r--target/linux/ath79/tiny/base-files/etc/board.d/01_leds7
-rw-r--r--target/linux/ath79/tiny/base-files/etc/board.d/02_network43
-rw-r--r--target/linux/ath79/tiny/base-files/etc/uci-defaults/09_fix-checksum1
8 files changed, 43 insertions, 46 deletions
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index bfc383c0e5..2974855870 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -242,13 +242,6 @@ dlink,dap-1365-a1)
ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "green:rssimediumhigh" "wlan0" "51" "100"
ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "green:rssihigh" "wlan0" "76" "100"
;;
-dlink,dap-1720-a1)
- ucidef_set_rssimon "wlan0" "200000" "1"
- ucidef_set_led_rssi "rssilow" "RSSI LOW" "red:signal-1" "wlan0" "1" "40"
- ucidef_set_led_rssi "rssimediumlow" "RSSI MEDIUM-LOW" "green:signal-1" "wlan0" "21" "100"
- ucidef_set_led_rssi "rssimediumhigh" "RSSI MEDIUM-HIGH" "green:signal-2" "wlan0" "61" "100"
- ucidef_set_led_rssi "rssihigh" "RSSI HIGH" "green:signal-3" "wlan0" "81" "100"
- ;;
engenius,ens202ext-v1|\
engenius,enstationac-v1)
ucidef_set_rssimon "wlan0" "200000" "1"
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index de9bd6a300..4c13478386 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -34,7 +34,6 @@ ath79_setup_interfaces()
devolo,dvl1750x|\
dlink,dap-1330-a1|\
dlink,dap-1365-a1|\
- dlink,dap-1720-a1|\
dlink,dap-2230-a1|\
dlink,dap-2660-a1|\
dlink,dap-2680-a1|\
diff --git a/target/linux/ath79/generic/base-files/etc/uci-defaults/09_fix-checksum b/target/linux/ath79/generic/base-files/etc/uci-defaults/09_fix-checksum
index 3f85fc12a0..4d961f26d2 100644
--- a/target/linux/ath79/generic/base-files/etc/uci-defaults/09_fix-checksum
+++ b/target/linux/ath79/generic/base-files/etc/uci-defaults/09_fix-checksum
@@ -21,7 +21,6 @@ dlink,dap-3320-a1|\
dlink,dap-3662-a1)
fixwrgg
;;
-dlink,dap-1720-a1|\
dlink,dir-629-a1|\
qihoo,c301)
fix_seama_header
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 03a0472c12..d19425a664 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1050,22 +1050,6 @@ define Device/dlink_dap-1365-a1
endef
TARGET_DEVICES += dlink_dap-1365-a1
-define Device/dlink_dap-1720-a1
- $(Device/seama)
- SOC := qca9563
- DEVICE_VENDOR := D-Link
- DEVICE_MODEL := DAP-1720
- DEVICE_VARIANT := A1
- DEVICE_PACKAGES := rssileds -swconfig \
- kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct
- SEAMA_SIGNATURE := wapac28_dlink.2015_dap1720
- IMAGE_SIZE := 15872k
- IMAGES += recovery.bin
- IMAGE/recovery.bin := $$(IMAGE/default) | pad-rootfs -x 64 | seama | \
- seama-seal | check-size
-endef
-TARGET_DEVICES += dlink_dap-1720-a1
-
define Device/dlink_dap-2xxx
IMAGES += factory.img
IMAGE/factory.img := append-kernel | pad-offset 6144k 160 | \
diff --git a/target/linux/ath79/image/tiny.mk b/target/linux/ath79/image/tiny.mk
index 13f105d202..955d0fbff2 100644
--- a/target/linux/ath79/image/tiny.mk
+++ b/target/linux/ath79/image/tiny.mk
@@ -12,6 +12,19 @@ define Device/buffalo_whr-g301n
endef
TARGET_DEVICES += buffalo_whr-g301n
+define Device/dlink_dap-1720-a1
+ $(Device/seama)
+ SOC := qca9563
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DAP-1720
+ DEVICE_VARIANT := A1
+ IMAGE_SIZE := 15872k
+ SEAMA_SIGNATURE := wapac28_dlink.2015_dap1720
+ DEVICE_PACKAGES := -swconfig ath10k-firmware-qca988x-ct \
+ kmod-ath10k-ct-smallbuffers rssileds
+endef
+TARGET_DEVICES += dlink_dap-1720-a1
+
define Device/dlink_dir-615-e4
SOC := ar7240
DEVICE_VENDOR := D-Link
diff --git a/target/linux/ath79/tiny/base-files/etc/board.d/01_leds b/target/linux/ath79/tiny/base-files/etc/board.d/01_leds
index 427eac8a06..76d14ebb71 100644
--- a/target/linux/ath79/tiny/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/tiny/base-files/etc/board.d/01_leds
@@ -20,6 +20,13 @@ tplink,tl-wr941-v4)
ucidef_set_led_switch "lan3" "LAN3" "green:lan3" "switch0" "0x08"
ucidef_set_led_switch "lan4" "LAN4" "green:lan4" "switch0" "0x10"
;;
+dlink,dap-1720-a1)
+ ucidef_set_rssimon "wlan0" "200000" "1"
+ ucidef_set_led_rssi "rssilow" "RSSI LOW" "red:signal-1" "wlan0" "1" "40"
+ ucidef_set_led_rssi "rssimediumlow" "RSSI MEDIUM-LOW" "green:signal-1" "wlan0" "21" "100"
+ ucidef_set_led_rssi "rssimediumhigh" "RSSI MEDIUM-HIGH" "green:signal-2" "wlan0" "61" "100"
+ ucidef_set_led_rssi "rssihigh" "RSSI HIGH" "green:signal-3" "wlan0" "81" "100"
+ ;;
dlink,dir-859-a1)
ucidef_set_led_switch "internet" "INTERNET" "green:internet" "switch0" "0x20"
;;
diff --git a/target/linux/ath79/tiny/base-files/etc/board.d/02_network b/target/linux/ath79/tiny/base-files/etc/board.d/02_network
index 60e640e0fb..fa2ea3aa6f 100644
--- a/target/linux/ath79/tiny/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/tiny/base-files/etc/board.d/02_network
@@ -12,27 +12,7 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
;;
- dlink,dir-615-e4|\
- netgear,wnr1000-v2|\
- netgear,wnr2000-v3|\
- netgear,wnr612-v2|\
- on,n150r|\
- tplink,tl-wr740n-v1|\
- tplink,tl-wr740n-v3|\
- tplink,tl-wr741-v1|\
- tplink,tl-wr743nd-v1|\
- tplink,tl-wr841-v5|\
- tplink,tl-wr941-v4)
- ucidef_set_interface_wan "eth0"
- ucidef_add_switch "switch0" \
- "0@eth1" "1:lan" "2:lan" "3:lan" "4:lan"
- ;;
- dlink,dir-859-a1|\
- dlink,dir-859-a3|\
- dlink,dir-869-a1)
- ucidef_add_switch "switch0" \
- "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5:wan"
- ;;
+ dlink,dap-1720-a1|\
engenius,eap350-v1|\
engenius,ecb350-v1|\
pqi,air-pen|\
@@ -63,6 +43,27 @@ ath79_setup_interfaces()
ubnt,nanostation-loco-m)
ucidef_set_interface_lan "eth0"
;;
+ dlink,dir-615-e4|\
+ netgear,wnr1000-v2|\
+ netgear,wnr2000-v3|\
+ netgear,wnr612-v2|\
+ on,n150r|\
+ tplink,tl-wr740n-v1|\
+ tplink,tl-wr740n-v3|\
+ tplink,tl-wr741-v1|\
+ tplink,tl-wr743nd-v1|\
+ tplink,tl-wr841-v5|\
+ tplink,tl-wr941-v4)
+ ucidef_set_interface_wan "eth0"
+ ucidef_add_switch "switch0" \
+ "0@eth1" "1:lan" "2:lan" "3:lan" "4:lan"
+ ;;
+ dlink,dir-859-a1|\
+ dlink,dir-859-a3|\
+ dlink,dir-869-a1)
+ ucidef_add_switch "switch0" \
+ "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5:wan"
+ ;;
engenius,enh202-v1)
ucidef_set_interface_lan "eth0"
ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/tiny/base-files/etc/uci-defaults/09_fix-checksum b/target/linux/ath79/tiny/base-files/etc/uci-defaults/09_fix-checksum
index 4febde5335..58e846f73f 100644
--- a/target/linux/ath79/tiny/base-files/etc/uci-defaults/09_fix-checksum
+++ b/target/linux/ath79/tiny/base-files/etc/uci-defaults/09_fix-checksum
@@ -8,6 +8,7 @@ fix_seama_header() {
board=$(board_name)
case "$board" in
+dlink,dap-1720-a1|\
dlink,dir-859-a1|\
dlink,dir-859-a3|\
dlink,dir-869-a1)