aboutsummaryrefslogtreecommitdiff
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2022-10-05 12:40:22 +1100
committerPetr Štetiar <ynezz@true.cz>2023-06-02 11:36:39 +0200
commit3a7c8fd15e89237c8c9db62393d057f3a47429d2 (patch)
tree1d6212fc4d178c121c3a02efa67ba98703144b09 /target/linux/x86/modules.mk
parent214e94cddf1bfd4e6141f79a70f532267fe1bea0 (diff)
kernel: kmod-amazon-ena: move to top level netdevices
The Amazon ENA network devices are also used on the AWS Arm (Graviton) instance types, so move it from the x86-only module file to the top level netdevices. Signed-off-by: Mathew McBride <matt@traverse.com.au>
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk17
1 files changed, 0 insertions, 17 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index f6a7c6c440..511410d614 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -2,23 +2,6 @@
#
# Copyright (C) 2017 Cezary Jackiewicz <cezary@eko.one.pll>
-define KernelPackage/amazon-ena
- SUBMENU:=$(NETWORK_DEVICES_MENU)
- TITLE:=Elastic Network Adapter (for Amazon AWS T3)
- DEPENDS:=@TARGET_x86_64
- KCONFIG:=CONFIG_ENA_ETHERNET
- FILES:=$(LINUX_DIR)/drivers/net/ethernet/amazon/ena/ena.ko
- AUTOLOAD:=$(call AutoLoad,12,ena)
-endef
-
-define KernelPackage/amazon-ena/description
- This driver supports Elastic Network Adapter (ENA)
- used by Amazon AWS T3 instances.
-endef
-
-$(eval $(call KernelPackage,amazon-ena))
-
-
define KernelPackage/amd-xgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=AMD Ethernet on SoC support