aboutsummaryrefslogtreecommitdiff
path: root/target/linux/sunxi/modules.mk
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2021-01-17 23:26:33 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2023-08-11 18:04:43 +0200
commitdc122f4d9e44adfd73c27111b00210ad2c0c3555 (patch)
treec154bde5e1995382303f4f5b6ad1dadf0ae5d4eb /target/linux/sunxi/modules.mk
parentc5988f4c01ff2e74a9588507b621d0ea5986cabe (diff)
sunxi: add modules for AC100 MFD and RTC
The X-Powers AC100 is a multi-function IC used to provide RTC and audio codec via RSB (reduced serial bus, an Allwinner- speciality). On some boards using the A80/A83T SoCs, aside from the RTC functionality, the RTC is used as a clocksource for the Ampak WiFi/BT modules. Add modules for the core MFD support and the RTC. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'target/linux/sunxi/modules.mk')
-rw-r--r--target/linux/sunxi/modules.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 8bbafe98a7..28ed86ba4c 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -2,6 +2,40 @@
#
# Copyright (C) 2013-2016 OpenWrt.org
+define KernelPackage/mfd-ac100
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=X-Powers AC100 MFD support
+ DEPENDS:=@TARGET_sunxi
+ KCONFIG:= \
+ CONFIG_MFD_AC100
+ FILES:=$(LINUX_DIR)/drivers/mfd/ac100.ko
+ AUTOLOAD:=$(call AutoLoad,50,ac100)
+endef
+
+define KernelPackage/mfd-ac100/description
+ Support for the X-Powers AC100 RTC/audio chip
+endef
+
+$(eval $(call KernelPackage,mfd-ac100))
+
+define KernelPackage/rtc-ac100
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=X-Powers AC100 RTC support
+ DEPENDS:=@TARGET_sunxi +kmod-mfd-ac100
+ $(call AddDepends/rtc)
+ KCONFIG:= \
+ CONFIG_RTC_DRV_AC100 \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-ac100.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-ac100)
+endef
+
+define KernelPackage/rtc-ac100/description
+ Support for the X-Powers AC100 RTC
+endef
+
+$(eval $(call KernelPackage,rtc-ac100))
+
define KernelPackage/rtc-sunxi
SUBMENU:=$(OTHER_MENU)
TITLE:=Sunxi SoC built-in RTC support