aboutsummaryrefslogtreecommitdiff
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorMieczyslaw Nalewaj <namiltd@yahoo.com>2024-02-23 20:53:37 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2024-02-24 19:23:03 +0100
commitfdd3a05c407d2d0793ec9434cd31197b15846f8d (patch)
tree41aef8151875b144d59ba3fd2ae0ff546bb5cda7 /target/linux/ramips
parent9092fa3a539d9e1729f1003813c7c60c27346a3a (diff)
ramips: add support for TP-Link Archer C5 v4
TP-Link Archer C5 v4 is a dual band router with 5 GbE ports Advertised as AC1200 for its 867Mbps (2x2) 5GHz band and 300 Mbps (2x2) 2.4GHz band. Specs: - SoC: MediaTek MT7620A - Ethernet: 5x GbE ports (Realtek RTL8367S) - Wireless 2.4GHz: MediaTek MT7620A - Wireless 5GHz: MediaTek MT7612E - RAM: 64MiB - ROM: 8MiB (GD25Q64CSIG) - 1 USB 2.0 port - 2 Buttons (WPS and reset) - 8 LEDs Flash instructions: Currently one has to install OpenWrt only via the serial console 1. Rename the factory.bin to to test.bin 2. start a TFTP server from IP address 192.168.0.225 and serve the image named test.bin 3. connect your device to the LAN port 4. power up the router and press 4 on the console to stop the boot process. 5. enter the following commands on the router console tftp 0x80060000 test.bin erase tplink 0x20000 0x7a0000 cp.b 0x80060000 0x20000 0x7a0000 reset Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn> [Update leds, add fast-read] Signed-off-by: Gaspare Bruno <gaspare@anlix.io> [Rebuilt version based on mt7620 tplink_archer.dtsi, support for external LNA, remove bad cell count info] Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/dts/mt7620a_tplink_archer-c5-v4.dts127
-rw-r--r--target/linux/ramips/image/mt7620.mk17
-rw-r--r--target/linux/ramips/mt7620/base-files/etc/board.d/01_leds4
-rw-r--r--target/linux/ramips/mt7620/base-files/etc/board.d/02_network7
4 files changed, 155 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7620a_tplink_archer-c5-v4.dts b/target/linux/ramips/dts/mt7620a_tplink_archer-c5-v4.dts
new file mode 100644
index 0000000000..4707bdf1e2
--- /dev/null
+++ b/target/linux/ramips/dts/mt7620a_tplink_archer-c5-v4.dts
@@ -0,0 +1,127 @@
+#include <dt-bindings/leds/common.h>
+
+#include "mt7620a_tplink_archer.dtsi"
+
+/ {
+ compatible = "tplink,archer-c5-v4", "ralink,mt7620a-soc";
+ model = "TP-Link Archer C5 v4";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ label-mac-device = &ethernet;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: led-0 {
+ function = LED_FUNCTION_POWER;
+ color = <LED_COLOR_ID_GREEN>;
+ gpios = <&gpio2 2 GPIO_ACTIVE_LOW>;
+ };
+
+ led-1 {
+ function = LED_FUNCTION_WLAN;
+ color = <LED_COLOR_ID_GREEN>;
+ function-enumerator = <2>;
+ gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ led-2 {
+ function = LED_FUNCTION_WLAN;
+ color = <LED_COLOR_ID_GREEN>;
+ function-enumerator = <5>;
+ gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ led-3 {
+ function = LED_FUNCTION_WAN;
+ color = <LED_COLOR_ID_GREEN>;
+ gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+ };
+
+ led-4 {
+ function = LED_FUNCTION_WAN;
+ color = <LED_COLOR_ID_ORANGE>;
+ gpios = <&gpio0 9 GPIO_ACTIVE_LOW>;
+ };
+
+ led-5 {
+ function = LED_FUNCTION_LAN;
+ color = <LED_COLOR_ID_GREEN>;
+ gpios = <&gpio0 8 GPIO_ACTIVE_HIGH>;
+ };
+
+ led-6 {
+ function = LED_FUNCTION_USB;
+ color = <LED_COLOR_ID_GREEN>;
+ gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+ trigger-sources = <&ohci_port1>, <&ehci_port1>;
+ linux,default-trigger = "usbport";
+ };
+
+ led-7 {
+ function = LED_FUNCTION_WPS;
+ color = <LED_COLOR_ID_GREEN>;
+ gpios = <&gpio0 1 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ rtl8367s {
+ compatible = "realtek,rtl8367b";
+ cpu_port = <7>;
+ realtek,extif2 = <1 0 1 1 1 1 1 1 2>;
+ mii-bus = <&mdio0>;
+ phy-id = <29>;
+ };
+};
+
+&spi0 {
+ flash@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "i2c", "uartf", "ephy", "rgmii2";
+ function = "gpio";
+ };
+};
+
+&ethernet {
+ pinctrl-names = "default";
+ pinctrl-0 = <&rgmii1_pins &mdio_pins>;
+
+ port@5 {
+ status = "okay";
+ mediatek,fixed-link = <1000 1 1 1>;
+ phy-mode = "rgmii";
+ };
+
+ mdio0: mdio-bus {
+ status = "okay";
+ reset-gpios = <&gpio2 20 GPIO_ACTIVE_LOW>;
+ reset-delay-us = <10000>;
+ };
+};
+
+&wmac {
+ pinctrl-names = "default", "pa_gpio";
+ pinctrl-0 = <&pa_pins>;
+ pinctrl-1 = <&pa_gpio_pins>;
+
+ nvmem-cells = <&eeprom_radio_0>, <&macaddr_rom_f100 0>;
+ nvmem-cell-names = "eeprom", "mac-address";
+};
+
+&wifi {
+ nvmem-cells = <&eeprom_radio_8000>, <&macaddr_rom_f100 2>;
+ nvmem-cell-names = "eeprom", "mac-address";
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 883aacabe0..4b35cb6f87 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -1214,6 +1214,23 @@ define Device/tplink_archer-c2-v1
endef
TARGET_DEVICES += tplink_archer-c2-v1
+define Device/tplink_archer-c5-v4
+ $(Device/tplink-v2)
+ SOC := mt7620a
+ IMAGE_SIZE := 7808k
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x04da857c
+ TPLINK_HWREV := 0x0c000600
+ TPLINK_HWREVADD := 0x04000000
+ IMAGES += tftp-recovery.bin
+ IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)
+ DEVICE_MODEL := Archer C5
+ DEVICE_VARIANT := v4
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport \
+ kmod-mt76x2 kmod-switch-rtl8367b
+endef
+TARGET_DEVICES += tplink_archer-c5-v4
+
define Device/tplink_archer-c50-v1
$(Device/tplink-v2)
SOC := mt7620a
diff --git a/target/linux/ramips/mt7620/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7620/base-files/etc/board.d/01_leds
index c4f7fcbb87..ffc5745e6f 100644
--- a/target/linux/ramips/mt7620/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7620/base-files/etc/board.d/01_leds
@@ -225,6 +225,10 @@ tplink,archer-c20i)
ucidef_set_led_switch "lan" "lan" "blue:lan" "switch0" "0x1e"
ucidef_set_led_switch "wan" "wan" "blue:wan" "switch0" "0x01"
;;
+tplink,archer-c5-v4)
+ ucidef_set_led_switch "lan" "lan" "green:lan" "switch1" "0x0f"
+ ucidef_set_led_switch "wan" "wan" "green:wan" "switch1" "0x10"
+ ;;
tplink,archer-c50-v1)
ucidef_set_led_switch "lan" "lan" "green:lan" "switch0" "0x1e"
ucidef_set_led_switch "wan" "wan" "green:wan" "switch0" "0x01"
diff --git a/target/linux/ramips/mt7620/base-files/etc/board.d/02_network b/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
index cbfb8a1d86..167bb47b69 100644
--- a/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7620/base-files/etc/board.d/02_network
@@ -235,6 +235,12 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"1:lan:3" "2:lan:4" "3:lan:1" "4:lan:2" "0:wan" "6@eth0"
;;
+ tplink,archer-c5-v4)
+ ucidef_add_switch "switch0"
+ ucidef_add_switch_attr "switch0" "enable" "0"
+ ucidef_add_switch "switch1" \
+ "0:lan:4" "1:lan:3" "2:lan:2" "3:lan:1" "4:wan" "7@eth0"
+ ;;
tplink,archer-mr200)
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "3:lan" "6t@eth0"
@@ -407,6 +413,7 @@ ramips_setup_macs()
tplink,archer-c2-v1|\
tplink,archer-c20-v1|\
tplink,archer-c20i|\
+ tplink,archer-c5-v4|\
tplink,archer-c50-v1|\
tplink,archer-mr200)
wan_mac=$(macaddr_add "$(mtd_get_mac_binary rom 0xf100)" 1)