aboutsummaryrefslogtreecommitdiff
path: root/target/linux/qualcommax/image/Makefile
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-06-11 19:32:52 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-06-16 11:11:08 +0200
commitf02f6aaa8d4e1025ab4aa9f569123e57f689f4e5 (patch)
treea5cd6920cb495282ceaa8ddbbb4adf9297b8e2b4 /target/linux/qualcommax/image/Makefile
parentde9955a62f6aab6eafb2cfdffc4829ee97e69c04 (diff)
ipq807x: rename target to qualcommax
Currently, ipq807x only covers Qualcomm IPQ807x SoC-s. However, Qualcomm also has IPQ60xx and IPQ50xx SoC-s under the AX WiSoC-s and they share a lot of stuff with IPQ807x, especially IPQ60xx so to avoid duplicating kernel patches and everything lets make a common target with per SoC subtargets. Start doing that by renaming ipq807x to qualcommax so that dependencies on ipq807x target can be updated. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/qualcommax/image/Makefile')
-rw-r--r--target/linux/qualcommax/image/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/qualcommax/image/Makefile b/target/linux/qualcommax/image/Makefile
new file mode 100644
index 0000000000..f59ad0c15f
--- /dev/null
+++ b/target/linux/qualcommax/image/Makefile
@@ -0,0 +1,17 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Device/Default
+ PROFILES := Default
+ KERNEL_LOADADDR := 0x41000000
+ DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
+ DEVICE_DTS_CONFIG := config@1
+ DEVICE_DTS_DIR := $(DTS_DIR)/qcom
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
+ IMAGE/sysupgrade.bin/squashfs :=
+endef
+
+include $(SUBTARGET).mk
+
+$(eval $(call BuildImage))