aboutsummaryrefslogtreecommitdiff
path: root/target/linux/loongarch64/base-files.mk
diff options
context:
space:
mode:
authorWeijie Gao <hackpascal@gmail.com>2024-01-07 03:10:45 +0800
committerChuanhong Guo <gch981213@gmail.com>2024-05-04 14:14:16 +0800
commit7fcb82665e96a50174084c8bfcd0302ce31291f4 (patch)
tree6693d4e3537166ccfff51c617659e50500163a9e /target/linux/loongarch64/base-files.mk
parent197d90dc31741a5510cd2218eff0befa935312cd (diff)
loongarch64: new target
Add target for Loongson LoongArch64-based boards. LoongArch is a new RISC ISA developed by Loongson. It's a bit like MIPS or RISC-V. LoongArch includes both 32-bit and 64-bit versions (LoongArch32/LoongArch64). Loongson 3A5000 and 3A6000 are the two existing CPUs of LoongArch64 and is used for PC products. It's BIOS supports ACPI and UEFI-only boot. These CPUs supports SMP and SMT. At present only LoongArch64 is supported by linux kernel. Toolchain requirement: binutils >= 2.40 gcc >= 13.1 For details, please check the following links: https://lwn.net/Articles/861951/ https://loongson.github.io/LoongArch-Documentation/README-EN.html Signed-off-by: Weijie Gao <hackpascal@gmail.com>
Diffstat (limited to 'target/linux/loongarch64/base-files.mk')
-rw-r--r--target/linux/loongarch64/base-files.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/loongarch64/base-files.mk b/target/linux/loongarch64/base-files.mk
new file mode 100644
index 0000000000..e2b7d05f57
--- /dev/null
+++ b/target/linux/loongarch64/base-files.mk
@@ -0,0 +1,8 @@
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
+ifeq ($(GRUB_SERIAL),)
+$(error This platform requires CONFIG_TARGET_SERIAL be set!)
+endif
+
+define Package/base-files/install-target
+ $(SED) "s#@GRUB_SERIAL@#$(GRUB_SERIAL)#" $(1)/etc/inittab
+endef