aboutsummaryrefslogtreecommitdiff
path: root/target/linux/ipq40xx/image/generic.mk
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-08-11 23:54:36 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-08-15 16:41:22 +0200
commit46ed38adeb76b376e34056c755e0c8ffa5acf29f (patch)
tree764a650079ca3c245dcd73ac21a2177d51f28df1 /target/linux/ipq40xx/image/generic.mk
parent0e6982b253b9c2ae0975aabe6318ad2d03f7d76c (diff)
ipq40xx: remove DK01 and DK04 boards
DK01 and DK04 board support has been in a form of 2 patches that we have been carrying for a long time. Both of the patches contain weird changes, dont follow any DT syntax and I honestly doubt they are even valid. DK01 and DK04 also have not been converted to DSA even after a long time and I doubt that anybody in the community even has these boards as they are QCA reference boards that are not even obtainable anymore. Since patches for these 2 boards have been just causing us pain when trying to update the kernel to a new major release or even point releases lets remove the support for these boards, and if there are users they can easily be reinstated. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ipq40xx/image/generic.mk')
-rw-r--r--target/linux/ipq40xx/image/generic.mk33
1 files changed, 0 insertions, 33 deletions
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 907558302c..dc5fbd6444 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -987,39 +987,6 @@ define Device/plasmacloud_pa2200
endef
TARGET_DEVICES += plasmacloud_pa2200
-define Device/qcom_ap-dk01.1-c1
- DEVICE_VENDOR := Qualcomm Atheros
- DEVICE_MODEL := AP-DK01.1
- DEVICE_VARIANT := C1
- BOARD_NAME := ap-dk01.1-c1
- SOC := qcom-ipq4019
- DEVICE_DTS := qcom-ipq4019-ap.dk01.1-c1
- KERNEL_INSTALL := 1
- KERNEL_SIZE := 4096k
- IMAGE_SIZE := 26624k
- $(call Device/FitImage)
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
- DEFAULT := n
-endef
-TARGET_DEVICES += qcom_ap-dk01.1-c1
-
-define Device/qcom_ap-dk04.1-c1
- $(call Device/FitImage)
- $(call Device/UbiFit)
- DEVICE_VENDOR := Qualcomm Atheros
- DEVICE_MODEL := AP-DK04.1
- DEVICE_VARIANT := C1
- SOC := qcom-ipq4019
- DEVICE_DTS := qcom-ipq4019-ap.dk04.1-c1
- KERNEL_INSTALL := 1
- KERNEL_SIZE := 4048k
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- BOARD_NAME := ap-dk04.1-c1
- DEFAULT := n
-endef
-TARGET_DEVICES += qcom_ap-dk04.1-c1
-
define Device/qxwlan_e2600ac-c1
$(call Device/FitImage)
DEVICE_VENDOR := Qxwlan