aboutsummaryrefslogtreecommitdiff
path: root/target/linux/generic/hack-6.1
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-01-26 17:27:08 +0000
committerDaniel Golle <daniel@makrotopia.org>2024-02-15 19:30:08 +0000
commit5a2eb8082f4126cc8881a5640602c52058b46e78 (patch)
treef409ab72015aa2b3a04d6bca73d79e819888527b /target/linux/generic/hack-6.1
parentbc25519f98cddbea3332e8ad02aac45aeea87fd6 (diff)
kernel: add driver for Airoha EN8811H PHY as module
Add PHY driver for Airoha EN8811H PHY and package it as kernel module. The PHY needs to load firmware from rootfs, so there is no point in having the driver built-into the kernel. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/generic/hack-6.1')
-rw-r--r--target/linux/generic/hack-6.1/700-swconfig_switch_drivers.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/generic/hack-6.1/700-swconfig_switch_drivers.patch b/target/linux/generic/hack-6.1/700-swconfig_switch_drivers.patch
index b213d804aa..673082d840 100644
--- a/target/linux/generic/hack-6.1/700-swconfig_switch_drivers.patch
+++ b/target/linux/generic/hack-6.1/700-swconfig_switch_drivers.patch
@@ -92,7 +92,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+
comment "MII PHY device drivers"
- config AMD_PHY
+ config AIR_EN8811H_PHY
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -24,6 +24,21 @@ libphy-$(CONFIG_LED_TRIGGER_PHY) += phy_