aboutsummaryrefslogtreecommitdiff
path: root/target/linux/d1
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-04-08 07:54:45 +0200
committerPaul Spooren <mail@aparcar.org>2024-04-08 21:52:51 +0200
commit3ce1e4c3d3da3885c2f42e1aa5bc97e0d421445b (patch)
tree66217da4480cd0d7f968c0037bff933d01418626 /target/linux/d1
parent0688cf5aebe1dc9a2e7f3820861783c2a7a75d44 (diff)
d1: define subtarget specifically
Historically it's possible to leave the `SUBTARGETS` undefined and automatically fallback to a "generic" subtarget. This however breaks various downstream scripts which may have expectations around filenames: While some targets with an explicit generic subtarget contain `generic` in the filenames of artifacts, implicit "subtargets" don't. Right now this breaks the CI[1], possibly also scripts using the ImageBuilders. Do to the D1 target what's done to other target, explicitly define the "generic" subtarget. [1]: https://github.com/openwrt/openwrt/actions/runs/8592821105/job/23548273630 Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/linux/d1')
-rw-r--r--target/linux/d1/Makefile1
-rw-r--r--target/linux/d1/generic/target.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/d1/Makefile b/target/linux/d1/Makefile
index 436ab94862..69e28d4811 100644
--- a/target/linux/d1/Makefile
+++ b/target/linux/d1/Makefile
@@ -9,6 +9,7 @@ BOARD:=d1
BOARDNAME:=AllWinner D1 RISC-V SoC
FEATURES:=ext4 squashfs
KERNELNAME:=Image dtbs
+SUBTARGETS:=generic
KERNEL_PATCHVER:=6.1
diff --git a/target/linux/d1/generic/target.mk b/target/linux/d1/generic/target.mk
new file mode 100644
index 0000000000..f5cb1fb19b
--- /dev/null
+++ b/target/linux/d1/generic/target.mk
@@ -0,0 +1 @@
+BOARDNAME:=Generic