aboutsummaryrefslogtreecommitdiff
path: root/target/linux/armsr/image
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2023-09-13 10:09:43 -0600
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-19 17:33:37 +0100
commitb10768476f9dc5178d0038e3877b14f95184e46e (patch)
tree2eaad3b9a740833ed7e8920e12c761f618b34846 /target/linux/armsr/image
parent5a64a482a24f79d246aea43191157aaf318622b8 (diff)
x86,armsr: interpolate GRUB_SERIAL into /etc/inittab
Some platforms have their console on other ports than ttyS0, so allow the developer to tailor this on bespoke platform images. Fixes issue #13401. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'target/linux/armsr/image')
-rw-r--r--target/linux/armsr/image/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/target/linux/armsr/image/Makefile b/target/linux/armsr/image/Makefile
index 1df9657385..e5be3fbe38 100644
--- a/target/linux/armsr/image/Makefile
+++ b/target/linux/armsr/image/Makefile
@@ -17,14 +17,10 @@ endif
GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
-ifneq ($(GRUB_SERIAL),)
- GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
- GRUB_TERMINALS += serial
-endif
+GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
+GRUB_TERMINALS += serial
-ifneq ($(GRUB_TERMINALS),)
- GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
-endif
+GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(IMG_PART_SIGNATURE)-02)