aboutsummaryrefslogtreecommitdiff
path: root/target/linux/armsr/image
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-08-09 06:36:39 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-08-15 15:55:00 +0200
commit7c5bdff9c472a3f008ac15cc1ccb81cd23b20e1f (patch)
tree77cfa631b0f8a06d24dea06fee9a77170767fbc1 /target/linux/armsr/image
parent15d3536c9deb2927c9a39350c6fa2e59f859df2a (diff)
armsr: add Marvell (Cavium) ThunderX2 network driver
The initial armv8 module incorrectly labelled the Thunder(v1) as supporting the ThunderX2, when they have different drivers. Add kmod-octeon-tx2 to support the newer devices. Signed-off-by: Mathew McBride <matt@traverse.com.au>
Diffstat (limited to 'target/linux/armsr/image')
-rw-r--r--target/linux/armsr/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/armsr/image/Makefile b/target/linux/armsr/image/Makefile
index e5153870d2..1df9657385 100644
--- a/target/linux/armsr/image/Makefile
+++ b/target/linux/armsr/image/Makefile
@@ -112,7 +112,7 @@ define Device/generic
kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
kmod-dwmac-rockchip kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom \
kmod-phy-marvell kmod-phy-marvell-10g kmod-sfp kmod-atlantic \
- kmod-bcmgenet
+ kmod-bcmgenet kmod-octeontx2-net
endef
TARGET_DEVICES += generic