aboutsummaryrefslogtreecommitdiff
path: root/target/linux/armsr/image
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2023-11-26 23:04:04 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-29 23:43:01 +0100
commit4211eab085ba38be024dc27731ee8135a671a8e8 (patch)
tree9b8ec4da635135663cb7dc990bde0dad120af28f /target/linux/armsr/image
parent6c118efc01a65c064934ec41b8108cb45e00c128 (diff)
target: Make TARGET_SERIAL independent of GRUB configuration
GRUB_SERIAL is also used for the default serial on the target and not only in grub. When no grub was build it was not available and the build fails. Rename GRUB_SERIAL to TARGET_SERIAL and make it always available on x86 and armsr targets. Fixes: #14063 Fixes: b10768476f9d ("x86,armsr: interpolate GRUB_SERIAL into /etc/inittab") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/armsr/image')
-rw-r--r--target/linux/armsr/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/armsr/image/Makefile b/target/linux/armsr/image/Makefile
index e5be3fbe38..ec566c5818 100644
--- a/target/linux/armsr/image/Makefile
+++ b/target/linux/armsr/image/Makefile
@@ -15,7 +15,7 @@ ifneq ($(CONFIG_GRUB_CONSOLE),)
GRUB_TERMINALS += console
endif
-GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
GRUB_TERMINALS += serial