aboutsummaryrefslogtreecommitdiff
path: root/target/linux/apm821xx/modules.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-05-31 14:15:56 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-06-01 23:54:17 +0200
commit9c1b3966150f9340b169f5adc1bf80dc1cfa54e0 (patch)
treedfb1afe8f4fb5a249043ba114b922685ada79124 /target/linux/apm821xx/modules.mk
parent93147443502e61d0a824406bef13b0b9fe250f71 (diff)
apm821xx: put crypto4xx into crypto subsection
module is only useful for apm821xx targets, so limit visability to just this target. Fixes: 55fbcad20a2d ("apm821xx: make crypto4xx as a standalone module") Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/apm821xx/modules.mk')
-rw-r--r--target/linux/apm821xx/modules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/apm821xx/modules.mk b/target/linux/apm821xx/modules.mk
index b837461157..f8880d6712 100644
--- a/target/linux/apm821xx/modules.mk
+++ b/target/linux/apm821xx/modules.mk
@@ -19,11 +19,12 @@ define KernelPackage/hw-crypto-4xx
CONFIG_HW_RANDOM=y \
CONFIG_CRYPTO_DEV_PPC4XX \
CONFIG_HW_RANDOM_PPC4XX=y
- DEPENDS:=+kmod-random-core +kmod-crypto-manager \
+ DEPENDS:=@TARGET_apm821xx +kmod-random-core +kmod-crypto-manager \
+kmod-crypto-ccm +kmod-crypto-gcm \
+kmod-crypto-sha1 +kmod-crypto-sha256 +kmod-crypto-sha512
FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.ko
AUTOLOAD:=$(call AutoLoad,09,sata_dwc_460ex,1)
+ $(call AddDepends/crypto)
endef
define KernelPackage/hw-crypto-4xx/description