aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorCheWei Chien <chewei.chien@wnc.com.tw>2024-01-04 13:28:40 +0800
committerChristian Marangi <ansuelsmth@gmail.com>2024-01-15 16:59:56 +0100
commitb33fa6ac9065028046016ea631f6be0926d7abd0 (patch)
treeaf11ebc7ffafbef28a1f55d4a78e0fd175b1ba34 /package
parentb38d446ecde356c48a40c51bfc9cc66d745b1056 (diff)
kernel: add kmod-leds-lp5562 and kmod-leds-lp55xx-common
Add kernel module for lp5562 LED driver. The kmod-leds-lp5562 depends on kmod-leds-lp55xx-common. Signed-off-by: CheWei Chien <chewei.chien@wnc.com.tw>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/leds.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index 24af1b7f61..60465a8ad5 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -261,3 +261,37 @@ define KernelPackage/input-leds/description
endef
$(eval $(call KernelPackage,input-leds))
+
+
+define KernelPackage/leds-lp55xx-common
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=LED common driver for LP5521/LP5523/LP55231/LP5562 controllers
+ DEPENDS:=+kmod-i2c-core
+ KCONFIG:=CONFIG_LEDS_LP55XX_COMMON
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-lp55xx-common.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-lp55xx-common,1)
+endef
+
+define KernelPackage/leds-lp55xx-common/description
+ This option enables support for Texas Instruments
+ LP5521/LP5523/LP55231/LP5562 common driver.
+endef
+
+$(eval $(call KernelPackage,leds-lp55xx-common))
+
+
+define KernelPackage/leds-lp5562
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=LED driver for LP5562 controllers
+ DEPENDS:=+kmod-i2c-core +kmod-leds-lp55xx-common
+ KCONFIG:=CONFIG_LEDS_LP5562
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-lp5562.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-lp5562,1)
+endef
+
+define KernelPackage/leds-lp5562/description
+ This option enables support for Texas Instruments LP5562
+ LED controllers.
+endef
+
+$(eval $(call KernelPackage,leds-lp5562)) \ No newline at end of file