aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2023-11-06 01:30:31 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-06 23:20:14 +0100
commita15eb1cda05d1a74146deb98edc61f0861c46852 (patch)
treeb7fead9c99cc2f8ac1fc276c6ad76312f8ce188a /package
parent3c17cdbc369d89ff6a7911c3acff2e493778f6c1 (diff)
bpf-headers: Fix download URL with kernel 6.1
This fixes the download of the kernel 5.15 for the bpf-headers when kernel 6.1 is build for the target. Even if kernel 6.1 was selected for the target we still use kernel 5.15 for the bpf-headers. The download script tried to download the 5.15 kernel from the 6.x directory on kernel,org and this failed. Define PKG_SOURCE_URL based on PKG_PATCHVER and not KERNEL_BASE like done in kernel.mk. Without this change it tries to download the kernel from this URL: ttps://cdn.kernel.org/pub/linux/kernel/v6.x/linux-5.15.129.tar.xz Fixes: #13190 Fixes: #13671 Fixes: #13814 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/bpf-headers/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/bpf-headers/Makefile b/package/kernel/bpf-headers/Makefile
index 733f358672..5efd2e1cf0 100644
--- a/package/kernel/bpf-headers/Makefile
+++ b/package/kernel/bpf-headers/Makefile
@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/kernel-$(PKG_PATCHVER)
PKG_VERSION:=$(PKG_PATCHVER)$(strip $(LINUX_VERSION-$(PKG_PATCHVER)))
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=$(LINUX_SITE)
+PKG_SOURCE_URL:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(PKG_PATCHVER))).x
PKG_HASH:=$(LINUX_KERNEL_HASH-$(strip $(PKG_VERSION)))
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/bpf-headers/$(PKG_NAME)-$(PKG_VERSION)