aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorSean Khan <datapronix@protonmail.com>2024-03-31 22:03:22 -0400
committerRobert Marko <robimarko@gmail.com>2024-04-01 19:44:45 +0200
commita0962e8c0435c5511059206c40dbab9dc522767c (patch)
treea56f6ef5e5861c16c462ffbec8e86a720979b184 /package
parent3e3e1b8bab94d5eb162604d4c198b426761598d7 (diff)
qca-nss-dp: cp instead of symlink for `nss_dp_arch.h`
Build files shouldn't be symlinked into the staging directory, as doing so would create a race condition if the build folder for 'qca-nss-dp' gets deleted for any reason. We should instead just copy over the required platform file to avoid breaking compilation for any dependent packages. Signed-off-by: Sean Khan <datapronix@protonmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/qca-nss-dp/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/qca-nss-dp/Makefile b/package/kernel/qca-nss-dp/Makefile
index e17446d236..167a9af4e4 100644
--- a/package/kernel/qca-nss-dp/Makefile
+++ b/package/kernel/qca-nss-dp/Makefile
@@ -39,7 +39,7 @@ EXTRA_CFLAGS+= \
NSS_DP_HAL_DIR:=$(PKG_BUILD_DIR)/hal
define Build/Configure
- $(LN) $(NSS_DP_HAL_DIR)/soc_ops/$(CONFIG_TARGET_SUBTARGET)/nss_$(CONFIG_TARGET_SUBTARGET).h \
+ $(CP) $(NSS_DP_HAL_DIR)/soc_ops/$(CONFIG_TARGET_SUBTARGET)/nss_$(CONFIG_TARGET_SUBTARGET).h \
$(PKG_BUILD_DIR)/exports/nss_dp_arch.h
endef