aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorJitao Lu <dianlujitao@gmail.com>2023-06-14 17:25:03 +0800
committerJitao Lu <dianlujitao@gmail.com>2023-06-14 21:16:15 +0800
commit51f57e7c2dd2799e34036ec74b3436bf490fade0 (patch)
treeb5f70d6f7f251d7044e0f794f0888fb9b4366b2e /package
parent8c1bd9b6a5056260393024a8d666f9367fac4885 (diff)
openssl: passing cflags to configure
openssl sets additional cflags in its configuration script. We need to make it aware of our custom cflags to avoid adding conflicting cflags. Fixes: #12866 Signed-off-by: Jitao Lu <dianlujitao@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/libs/openssl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index a34a784973..0d09114f06 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=3.0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_BUILD_FLAGS:=no-mips16 gc-sections
PKG_BUILD_PARALLEL:=1
@@ -366,6 +366,7 @@ define Build/Configure
--libdir=lib \
--openssldir=/etc/ssl \
--cross-compile-prefix="$(TARGET_CROSS)" \
+ $(TARGET_CFLAGS) \
$(TARGET_CPPFLAGS) \
$(TARGET_LDFLAGS) \
$(OPENSSL_OPTIONS) && \