aboutsummaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2024-03-15 12:50:14 +0100
committerRobert Marko <robimarko@gmail.com>2024-03-15 15:25:03 +0100
commit08f1c36d0081ca183dce2c17cd5d0692ad63e430 (patch)
treeacc4b7dff4ebaf27eae66283d04da95b2eb0aae7 /package
parenta6b3cc95f2e079a9924a225e343bdf9cb8b35d21 (diff)
kernel: modules: video: package DRM suballocation helper
Linux 6.4 has split out the previously AMDGPU specific suballocation helper into a generic one and it has its own symbol now. So, lets package it as a separate helper as AMDGPU still requires it for 6.6. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/video.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 73c94e391c..1e12ffbb40 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -353,6 +353,22 @@ endef
$(eval $(call KernelPackage,drm-kms-helper))
+define KernelPackage/drm-suballoc-helper
+ SUBMENU:=$(VIDEO_MENU)
+ HIDDEN:=1
+ TITLE:=DRM suballocation helper
+ DEPENDS:=@DISPLAY_SUPPORT +kmod-drm @LINUX_6_6
+ KCONFIG:=CONFIG_DRM_SUBALLOC_HELPER
+ FILES:=$(LINUX_DIR)/drivers/gpu/drm/drm_suballoc_helper.ko
+ AUTOLOAD:=$(call AutoProbe,drm_suballoc_helper)
+endef
+
+define KernelPackage/drm-suballoc-helper/description
+ DRM suballocation helper.
+endef
+
+$(eval $(call KernelPackage,drm-suballoc-helper))
+
define KernelPackage/drm-amdgpu
SUBMENU:=$(VIDEO_MENU)
TITLE:=AMDGPU DRM support