aboutsummaryrefslogtreecommitdiff
path: root/package/utils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-10-06 21:55:01 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-25 17:55:03 +0100
commit8a8d68cf030b9d30309c38fbdb28b236ceac88b1 (patch)
tree1ea4a75665ac9205347ae3d159e834b02b8864b9 /package/utils
parent2a0c9cc8cdaa76414993deaff3371dba294638db (diff)
f2fs-tools: avoid dead symlinks in root
When building on the host, this avoids creating dead symlinks. Matches what is done elsewhere. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/f2fs-tools/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/utils/f2fs-tools/Makefile b/package/utils/f2fs-tools/Makefile
index 27a6fd2248..d5dc1a6d78 100644
--- a/package/utils/f2fs-tools/Makefile
+++ b/package/utils/f2fs-tools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=f2fs-tools
PKG_VERSION:=1.16.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
@@ -133,10 +133,10 @@ Package/mkf2fs-selinux/install = $(Package/mkf2fs/install)
define Package/f2fsck/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fsck.f2fs $(1)/usr/sbin
- ln -s /usr/sbin/fsck.f2fs $(1)/usr/sbin/defrag.f2fs
- ln -s /usr/sbin/fsck.f2fs $(1)/usr/sbin/dump.f2fs
- ln -s /usr/sbin/fsck.f2fs $(1)/usr/sbin/sload.f2fs
- ln -s /usr/sbin/fsck.f2fs $(1)/usr/sbin/resize.f2fs
+ $(LN) ../sbin/fsck.f2fs $(1)/usr/sbin/defrag.f2fs
+ $(LN) ../sbin/fsck.f2fs $(1)/usr/sbin/dump.f2fs
+ $(LN) ../sbin/fsck.f2fs $(1)/usr/sbin/sload.f2fs
+ $(LN) ../sbin/fsck.f2fs $(1)/usr/sbin/resize.f2fs
endef
Package/f2fsck-selinux/install = $(Package/f2fsck/install)