aboutsummaryrefslogtreecommitdiff
path: root/package/utils
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-11-10 21:14:29 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-10 21:16:09 +0100
commit79ee0d2ceead54edae002c3bd0460d3abc645ce0 (patch)
tree7b54f30aa0bee69e922b0b6e5510fb12a778aac8 /package/utils
parent8376eaaa2805c6ea41ca88a4cc2304731c91798e (diff)
debugcc: add new package to debug IPQ based SoC clocks
Add new package to debug IPQ clocks using debug regs and hardware oscillator. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/debugcc/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/utils/debugcc/Makefile b/package/utils/debugcc/Makefile
new file mode 100644
index 0000000000..961c041047
--- /dev/null
+++ b/package/utils/debugcc/Makefile
@@ -0,0 +1,29 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=debugcc
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=https://github.com/linux-msm/debugcc.git
+PKG_SOURCE_DATE:=2023-11-10
+PKG_SOURCE_VERSION:=d15bea7c05f224a85dd1fcec24b0f153dbad9f6e
+PKG_MIRROR_HASH:=b6bd181db4992cf429343cd7d0fdde0f937a8f1811f5fe9e7855a0d76b0d88a0
+
+PKG_MAINTAINER:=Christian Marangi <ansuelsmth@gmail.com>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/meson.mk
+
+define Package/debugcc
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=QCOM debugcc utility
+ DEPENDS:=@KERNEL_DEVMEM @(TARGET_qualcommax||TARGET_ipq806x||TARGET_ipq40xx)
+endef
+
+define Package/debugcc/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(MESON_BUILD_DIR)/debugcc $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,debugcc))