aboutsummaryrefslogtreecommitdiff
path: root/package/utils/ucode-mod-bpf/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-01-08 20:40:40 +0100
committerFelix Fietkau <nbd@nbd.name>2023-01-09 11:35:20 +0100
commit0cc1c302b188f905ccf081d8f3984cee27bd7524 (patch)
treede15997a1c12c1ad9b38aedf5d727805fb9c3812 /package/utils/ucode-mod-bpf/Makefile
parentd6a284e4cea46129a18542c6f23309b7bf1af174 (diff)
ucode-mod-bpf: add new package for a ucode libbpf binding
The bpf plugin provides functionality for loading and interacting with eBPF modules. It allows loading full modules and pinned maps/programs and supports interacting with maps and attaching programs as tc classifiers. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/utils/ucode-mod-bpf/Makefile')
-rw-r--r--package/utils/ucode-mod-bpf/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/utils/ucode-mod-bpf/Makefile b/package/utils/ucode-mod-bpf/Makefile
new file mode 100644
index 0000000000..a748b9dbbd
--- /dev/null
+++ b/package/utils/ucode-mod-bpf/Makefile
@@ -0,0 +1,40 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ucode-mod-bpf
+PKG_RELEASE:=1
+PKG_LICENSE:=ISC
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/ucode-mod-bpf
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=ucode eBPF module
+ DEPENDS:=+libucode +libbpf
+endef
+
+define Package/ucode-mod-bpf/description
+The bpf plugin provides functionality for loading and interacting with
+eBPF modules.
+
+It allows loading full modules and pinned maps/programs and supports
+interacting with maps and attaching programs as tc classifiers.
+endef
+
+define Package/ucode-mod-bpf/install
+ $(INSTALL_DIR) $(1)/usr/lib/ucode
+ $(CP) $(PKG_BUILD_DIR)/bpf.so $(1)/usr/lib/ucode/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) $(FPIC) \
+ -Wall -ffunction-sections -Wl,--gc-sections -shared -Wl,--no-as-needed -lbpf \
+ -o $(PKG_BUILD_DIR)/bpf.so $(PKG_BUILD_DIR)/bpf.c
+endef
+
+$(eval $(call BuildPackage,ucode-mod-bpf))