aboutsummaryrefslogtreecommitdiff
path: root/package/utils/f2fs-tools/Makefile
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-07-04 09:52:43 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-04 20:24:06 +0200
commita0c5b03e02528b938f1c6d411a582b67b7e9fe7b (patch)
tree4c10bf22bbfe96352bca0f7b35cd8c9024b183f7 /package/utils/f2fs-tools/Makefile
parentf58e562b07803192d029a6be8c8c372e1ed11c68 (diff)
f2fs-tools: import patch to fix compilation
Disable lz4 and lzo2 manually. Fixes errors in the form of: Package f2fsck is missing dependencies for the following libraries: liblz4.so.1 liblzo2.so.2 Fixes: 8b9e80616011 ("f2fs-tools: update to 1.15.0") Acked-by: Thomas Huehn <thomas.huehn@hs-nordhausen.de> Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/utils/f2fs-tools/Makefile')
-rw-r--r--package/utils/f2fs-tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/utils/f2fs-tools/Makefile b/package/utils/f2fs-tools/Makefile
index 8f53516d34..60f4b317c7 100644
--- a/package/utils/f2fs-tools/Makefile
+++ b/package/utils/f2fs-tools/Makefile
@@ -99,7 +99,9 @@ endef
CONFIGURE_ARGS += \
--disable-static \
- --without-blkid
+ --without-blkid \
+ --without-lzo2 \
+ --without-lz4
ifneq ($(BUILD_VARIANT),selinux)
CONFIGURE_ARGS += --without-selinux