aboutsummaryrefslogtreecommitdiff
path: root/package/system/ubus/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2024-03-17 18:43:10 +0100
committerPaul Spooren <mail@aparcar.org>2024-03-22 22:14:22 +0100
commite8725a932e16eaf6ec51add8c084d959cbe32ff2 (patch)
tree1e6e0a3731bf9c4860b6d13fa08bea226f999a6f /package/system/ubus/Makefile
parent36acf88fe0d974a7de5c3be5d3303048c54ce6fb (diff)
treewide: use APK compatible version schema
Different from OPKG, APK uses a deterministic version schema which chips the version into chunks and compares them individually. This enforces a certain schema which was previously entirely flexible. - Releases are added at the very and end prefixed with an `r` like `1.2.3-r3`. - Hashes are prefixed with a `~` like `1.2.3~abc123`. - Dates become semantic versions, like `2024.04.01` - Extra tags are possible like `_git`, `_alpha` and more. For full details see the APK test list: https://gitlab.alpinelinux.org/alpine/apk-tools/-/blob/master/test/version.data Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'package/system/ubus/Makefile')
-rw-r--r--package/system/ubus/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/ubus/Makefile b/package/system/ubus/Makefile
index fdf16cfeee..fddc36b0dd 100644
--- a/package/system/ubus/Makefile
+++ b/package/system/ubus/Makefile
@@ -7,7 +7,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/ubus.git
PKG_SOURCE_DATE:=2023-11-28
PKG_SOURCE_VERSION:=f84eb5998c6ea2d34989ca2d3254e56c66139313
-PKG_MIRROR_HASH:=d0c15a0275fa3d35accddb84611700bf601745ad68462bc18905bb65da931f21
+PKG_MIRROR_HASH:=75f39a88a6b019ae95c73ed3f7373e5197aa1ff29dc9a95ea46483412f4051ae
PKG_ABI_VERSION:=$(call abi_version_str,$(PKG_SOURCE_DATE))
CMAKE_INSTALL:=1