aboutsummaryrefslogtreecommitdiff
path: root/package/libs/uclibc++/patches/002-undef-functions.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-26 20:17:46 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-24 18:20:50 +0200
commit6b2ed6101e4c97691ba3aa94f25895be536b3870 (patch)
tree98ee702823e44b2f6fdb148b5eb53753bfa3cbef /package/libs/uclibc++/patches/002-undef-functions.patch
parent09465d802b8ce37ee87b6d104889059a6fa948e6 (diff)
uclibc++: remove
No package here depends on it. Furthermore, uClibc++ is a fairly buggy C++ library and seems to be relatively inactive upstream. It also lacks proper support for modern C++11 features. The main benefit of it is size: 66.6 KB vs 287.3 KB on mips24kc. Static linking and LTO can help bring the size down of packages that need it. Added warning message to uclibc++.mk Signed-off-by: Rosen Penev <rosenp@gmail.com> Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/libs/uclibc++/patches/002-undef-functions.patch')
-rw-r--r--package/libs/uclibc++/patches/002-undef-functions.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/package/libs/uclibc++/patches/002-undef-functions.patch b/package/libs/uclibc++/patches/002-undef-functions.patch
deleted file mode 100644
index 47fa1580f2..0000000000
--- a/package/libs/uclibc++/patches/002-undef-functions.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 8245f62c1e7aba150f666b3c3a1dda646dee6d4b Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 27 Sep 2019 13:12:44 -0700
-Subject: [PATCH] cstdio: Add undef for four functions
-
-When compiling with uClibc-ng, these functions get defined as macros and
-become unavailable for std.
-
-Fixes programs that use the std versions of these functions.
-
-This matches libstdcpp behavior.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- include/cstdio | 9 +++++++++
- 1 file changed, 9 insertions(+)
-
---- a/include/cstdio
-+++ b/include/cstdio
-@@ -21,6 +21,15 @@
- #ifndef __HEADER_CSTDIO
- #define __HEADER_CSTDIO 1
-
-+#undef clearerr
-+#undef feof
-+#undef ferror
-+#undef fgetc
-+#undef fputc
-+#undef getc
-+#undef getchar
-+#undef putc
-+#undef putchar
-
- namespace std{
- using ::FILE;