aboutsummaryrefslogtreecommitdiff
path: root/package/kernel
diff options
context:
space:
mode:
authorDaniel Maslowski <info@orangecms.org>2023-09-14 21:56:58 +0200
committerAlexander Couzens <lynxis@fe80.eu>2023-09-14 23:44:14 +0200
commitc1206675a4c23e3ec93599a705becc141c71c675 (patch)
tree54d7f8ab092c24766253fd3ac250a938ba89466e /package/kernel
parent66315993445c8dbd29a5b7a16d3761edebf074d9 (diff)
kernel: decouple 9P virtio from 9P net
General support for 9P is desirable on platforms without virtualization. This decouples the 9P general networking support for use on more platforms. Signed-off-by: Daniel Maslowski <info@orangecms.org>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netsupport.mk27
1 files changed, 21 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 5b978bae7b..fcf327b434 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1324,17 +1324,13 @@ $(eval $(call KernelPackage,mpls))
define KernelPackage/9pnet
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Plan 9 Resource Sharing Support (9P2000)
- DEPENDS:=@VIRTIO_SUPPORT
KCONFIG:= \
CONFIG_NET_9P \
CONFIG_NET_9P_DEBUG=n \
- CONFIG_NET_9P_XEN=n \
- CONFIG_NET_9P_VIRTIO \
CONFIG_NET_9P_FD=n@ge5.17
FILES:= \
- $(LINUX_DIR)/net/9p/9pnet.ko \
- $(LINUX_DIR)/net/9p/9pnet_virtio.ko
- AUTOLOAD:=$(call AutoLoad,29,9pnet 9pnet_virtio)
+ $(LINUX_DIR)/net/9p/9pnet.ko
+ AUTOLOAD:=$(call AutoLoad,29,9pnet)
endef
define KernelPackage/9pnet/description
@@ -1344,6 +1340,25 @@ endef
$(eval $(call KernelPackage,9pnet))
+define KernelPackage/9pvirtio
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Plan 9 Virtio Support
+ DEPENDS:=+kmod-9pnet @VIRTIO_SUPPORT
+ KCONFIG:= \
+ CONFIG_NET_9P_XEN=n \
+ CONFIG_NET_9P_VIRTIO
+ FILES:= \
+ $(LINUX_DIR)/net/9p/9pnet_virtio.ko
+ AUTOLOAD:=$(call AutoLoad,29,9pnet_virtio)
+endef
+
+define KernelPackage/9pvirtio/description
+ Kernel support support for
+ Plan 9 resource sharing for virtio.
+endef
+
+$(eval $(call KernelPackage,9pvirtio))
+
define KernelPackage/nlmon
SUBMENU:=$(NETWORK_SUPPORT_MENU)