aboutsummaryrefslogtreecommitdiff
path: root/package/kernel
diff options
context:
space:
mode:
authorDaniel Kestrel <kestrel1974@t-online.de>2022-02-14 21:50:06 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2024-02-02 15:07:07 +0100
commitbb46f0484d7017366f27f40d139562b262123303 (patch)
treef03410e3f5cdbe0f31636fffbbc93e2c39090d3e /package/kernel
parentc34651c423b69ac8ccf7f72d468d4f19ac6370a2 (diff)
lantiq: add support for AVM Fritzbox 7490
This adds support for the Fritzbox 7490 device. It contains two SoCs, one Lantiq without WiFi and one QCA9558 with 2.4GHz and 5 GHz WiFi. Only the Lantiq has access to the flash memory, the Atheros runs fully from RAM and is booted by using a remoteproc kernel module and is not supported with this commit. The devices were manufactured with varying NAND chips which requires Micron and non-Micron versions of the images. Specifications: - SoC: Lantiq 500 MHz - RAM: 256 MB - Storage: 512 MB NAND, 1MB FLASH - Wireless, separate SOC QCA9558 with 128MB RAM (not supported yet): · Qualcomm-QCA9558 w/ 3×3 MIMO for 2.4GHz 802.11b/g/n · Qualcomm-QCA9880 w/ 3×3 MIMO for 5GHz 802.11a/ac · AG71xx ethernet - Ethernet: Built-in AR 803x, 7 port 4 phy switch, 4x 1000/100/10 port, Port 5 is fixed and connected to the WASP SOC - Renesas µPD720202 USB3 PCIe, requires firmware binary on the device - VDSL2 modem Unsupported: - DECT and ISDN telephony Installation: Check which NAND the device has by using the following procedure with stock firmware: Go to to http://<fritzbox_ip>/support.lua, download the support data file and search for string "NAND device" to get the manufacturer kernel output. Use Micron image if Micron is displayed otherwise the non-Micron image. Use the eva_ramboot.py script to boot the initramfs image. Follow the procedure to interrupt booting by ftp into 192.168.178.1 within 5 seconds after poweron. Then transfer the sysupgrade image to the device and run sysupgrade to flash it to the NAND. For making USB work, an renesas xhci firmware file (e.g. v2026) is needed and it should be copied to /lib/firmware/ (file name renesas_usb_fw.mem). Signed-off-by: Daniel Kestrel <kestrel1974@t-online.de>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/usb.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 6218ec994c..7f9e627fdb 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1739,6 +1739,7 @@ define KernelPackage/usb3
+TARGET_ramips_mt7621:kmod-usb-xhci-mtk \
+TARGET_mediatek:kmod-usb-xhci-mtk \
+TARGET_apm821xx_nand:kmod-usb-xhci-pci-renesas \
+ +TARGET_lantiq_xrx200:kmod-usb-xhci-pci-renesas \
+TARGET_mvebu_cortexa9:kmod-usb-xhci-pci-renesas
KCONFIG:= \
CONFIG_USB_PCI=y \