aboutsummaryrefslogtreecommitdiff
path: root/package/kernel
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-10-14 20:48:28 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-02-09 14:01:51 +0100
commita79efe4cdf4531f4fef2bc0b73ad25046151673b (patch)
tree7406e74f36e3131cd35ae6a3ea1e44f8b0b6a288 /package/kernel
parent5a016cc3af3ee96a0df6bc45debb8394e6e7067d (diff)
qca-ssdk: add support for ipq60xx
IPQ60xx uses a different codename for SSDK, so lets pass the correct one as otherwise SSDK asumes we are building for the old MIPS SoC-s. Signed-off-by: Robert Marko <robimarko@gmail.com> [ drop outdated commit description info ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/qca-ssdk/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/kernel/qca-ssdk/Makefile b/package/kernel/qca-ssdk/Makefile
index 2517b80069..7eccdaa1d7 100644
--- a/package/kernel/qca-ssdk/Makefile
+++ b/package/kernel/qca-ssdk/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qca-ssdk
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE_URL:=https://git.codelinaro.org/clo/qsdk/oss/lklm/qca-ssdk.git
PKG_SOURCE_PROTO:=git
@@ -53,6 +53,10 @@ ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")
MAKE_FLAGS+= CHIP_TYPE=HPPE
endif
+ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq60xx")
+ MAKE_FLAGS+= CHIP_TYPE=CPPE
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/qca-ssdk
$(INSTALL_DIR) $(1)/usr/include/qca-ssdk/api