aboutsummaryrefslogtreecommitdiff
path: root/package/kernel
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-11-14 09:22:40 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-14 05:21:55 +0100
commit853db7be9521e67588acaf15e5600d911e5f8253 (patch)
tree4f034a15c966bfbc20e873b76a3217a36e7e9d41 /package/kernel
parentc885169e02a56a889f706b7734599ac42dcf9886 (diff)
qca-ssdk: pass SoC to build
Recent SSDK versions started also parsing the "SoC" variable to identify the SoC along with the "CHIP_TYPE". We are not passing "SoC" currently and this leads to components we dont need like MHT (New 2.5G quad port switch) being compiled and then unused, so lets just pass the "SoC" as well. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/qca-ssdk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/qca-ssdk/Makefile b/package/kernel/qca-ssdk/Makefile
index 4107208c0e..ab978f3b49 100644
--- a/package/kernel/qca-ssdk/Makefile
+++ b/package/kernel/qca-ssdk/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qca-ssdk
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=https://git.codelinaro.org/clo/qsdk/oss/lklm/qca-ssdk.git
PKG_SOURCE_PROTO:=git
@@ -43,6 +43,7 @@ MAKE_FLAGS+= \
TARGET_SUFFIX=$(CONFIG_TARGET_SUFFIX) \
GCC_VERSION=$(GCC_VERSION) \
EXTRA_CFLAGS=-fno-stack-protector -I$(STAGING_DIR)/usr/include \
+ SoC=$(CONFIG_TARGET_SUBTARGET) \
$(LNX_CONFIG_OPTS)
ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")