aboutsummaryrefslogtreecommitdiff
path: root/package/kernel
diff options
context:
space:
mode:
authorAviana Cruz <gwencroft@proton.me>2022-06-20 21:55:45 +0800
committerChristian Marangi <ansuelsmth@gmail.com>2023-09-12 14:57:54 +0200
commit46d673033b7f6974d0bf5696ff8365fd412cd646 (patch)
treed8a366928f1d65398544711f623b329d23c749ee /package/kernel
parent47d56ae5463f1965750d3f75390c96d69f969145 (diff)
ramips: add support for mtk eip93 crypto engine
Mediatek EIP93 Crypto engine is a crypto accelerator which is available in the Mediatek MT7621 SoC. Signed-off-by: Aviana Cruz <gwencroft@proton.me> Co-authored-by: Richard van Schagen <vschagen@icloud.com> Co-authored-by: Chukun Pan <amadeus@jmu.edu.cn>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 248b4d68f9..501be4b0a0 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -463,6 +463,35 @@ endef
$(eval $(call KernelPackage,crypto-hw-talitos))
+define KernelPackage/crypto-hw-eip93
+ TITLE:=MTK EIP93 crypto module
+ DEPENDS:=@TARGET_ramips_mt7621 \
+ +kmod-crypto-authenc \
+ +kmod-crypto-des \
+ +kmod-crypto-md5 \
+ +kmod-crypto-sha1 \
+ +kmod-crypto-sha256
+ KCONFIG:= \
+ CONFIG_CRYPTO_HW=y \
+ CONFIG_CRYPTO_DEV_EIP93 \
+ CONFIG_CRYPTO_DEV_EIP93_AES=y \
+ CONFIG_CRYPTO_DEV_EIP93_DES=y \
+ CONFIG_CRYPTO_DEV_EIP93_AEAD=y \
+ CONFIG_CRYPTO_DEV_EIP93_GENERIC_SW_MAX_LEN=256 \
+ CONFIG_CRYPTO_DEV_EIP93_AES_128_SW_MAX_LEN=512
+ FILES:=$(LINUX_DIR)/drivers/crypto/mtk-eip93/crypto-hw-eip93.ko
+ AUTOLOAD:=$(call AutoLoad,09,crypto-hw-eip93)
+ $(call AddDepends/crypto)
+endef
+
+define KernelPackage/crypto-hw-eip93/description
+Kernel module to enable EIP-93 Crypto engine as found
+in the Mediatek MT7621 SoC.
+It enables DES/3DES/AES ECB/CBC/CTR and
+IPSEC offload with authenc(hmac(sha1/sha256), aes/cbc/rfc3686)
+endef
+
+$(eval $(call KernelPackage,crypto-hw-eip93))
define KernelPackage/crypto-kpp
TITLE:=Key-agreement Protocol Primitives